2.5W diode Bachin GRBL1.1F

Hello all. In need of some help. i have a 2.5W bachin diode. having problems burning. i read forms on here. tried ways explained in them. but still not sure what im doing wrong or the machine itself, most likely its me. if i run it at 50mm/min 100% power. i get a burn but its a 7+ hour job for a 4.25x4.75inch birch wood. if i lower the power to anything below 70% i dont get nothing at all. unless i use the baking soda water trick. im not sure if its because its only a 2500mw laser or settings arent matching up right. if i turn 32=0. everything comes out perfect, but i dont want to wait 24+ hours for a job to get done.
i am running grbl 1.1f
here are my $$ settings:


































these settings have been reset btw so i can start from scratch. (but for 32,100,101)
sorry, i know this topic has been covered before, a number of times.
edit: i did lower 110 111 to 5000 for last picture.

If you could also drop a picture of the ‘cuts/layers’.
It could be it’s a hi def picture, could try dropping the ‘dpi’.
Hard to say without seeing the settings, if you’re using grayscale, dither etc.
Someone i’m sure shall be along soon to help out…

Ok thanks kris. I’ll up load them asap.

First one is laser on, second one is laser off. DPI set at 200Dpi i do believe.

This one was ran a little bit ago. Took 5 hours. Only 4.25x2.75in. Power 72.50. Speed 150.
Started low on power and kept bumping up and bumping down speed until I saw a burn mark and let it ran to see what came out of it


150 mm/min is very slow. What do you mean in the one post, “first one is laser on, second is laser off” - The second one looks much more like what I’d expect to see for your power and speed setting.

32=1 for the first 32=0 for the second.

The only thing I can think of then is that Bachin has messed up GRBL, because there is no way that the speeds you are running are a problem, and your firmware is set to allow up to 6000 mm/min. Try changing $30 and S-Value max in the device settings to 255 instead of 1000, and see if that works. If the Bachin version of GRBL has a bug, that might be it.

ive tried 255. still comes out the same. if its a bug problem, is there a way i can fix it? like the debug option under LB’s edit option or something?

It’s possible that because your board is set to 9600 baud, it’s simply not able to receive data fast enough, and is slowing down a lot. Will it only connect if you use 9600? If so, that is going to really limit how fast you are able to go, since the board will consume gcode instructions faster than you can send them.

i believe so, i tried changing it in “Engraver Master” program that came with the machine. 115200 i believe. it connects to machine but laser doesnt move, turns on laser, connects to it. just doesnt move.

but that also changes grbl to 1.1z? i think?

honestly, i dont believe i tried changing it in lightburn program itself while staying with the 1.1F
im not sure if i was able to do that or not. new to it and didnt wanna change a bunch and mess it all up.

Had to do a manual set up to find machine. i followed forms. wouldnt detect right away. i left LB open on accident while i opened engraver master. when i closed engraver master, LB picked up all its settings and detected it. havent touched that since then. ive noticed that my 100 and 101 is set lower then others ive seen on forms. in engraver master it has to be set at 145, in LB it has to be set at 50? im not sure why. other wise the laser doesnt move the proper distance.

@LightBurn, ok my project test run just finished up. 17 hours 27 mins later. but i went into settings in LB changed baud to115200. jacked up the speed to 300. its burning now. with the settings above, whats the max speed i can do without the machine cutting power in half?

It depends on the image content honestly - 8-bit GRBL can only process about 200 GCode instructions per second, so at 254 DPI, that’s a maximum of 10 instructions per mm, but usually a little less, so 20mm/sec (1200 mm/min) would be the approximate max at 254 DPI. It’ll go up as your DPI reduces, and if the picture doesn’t have much perfect 50% gray in it, you’ll be safe at 1500 mm/min.

ok sorry i lied. if i close LB while not on 9600 baud, when i open it, it dose not connect to machine. i have to manually select the options. when it loads up in 9600, the command window says:
Waiting for connection…

Waiting for connection…

Grbl 1.1f @57600 [’$’ for help]



[VER:1.1f @57600.20170801:NXD5-CJ5E-8JV4-FCTM]


Target buffer size found

it will only connect with 9600. and again wont burn on new piece without the soda treatment.
these are my settings now. looks like 110 111 have changed

$0=10 $1=254 $2=0 $3=2 $4=0 $5=0 $6=0 $10=0 $11=0.010 $12=0.002 $13=0 $20=0 $21=0 $22=0 $23=0 $24=25.000 $25=500.000 $26=250 $27=1.000 $30=1000 $31=0 $32=0 $100=50.000 $101=50.000 $102=250.000 $110=5000.000 $111=5000.000 $112=500.000 $120=600.000 $121=600.000 $122=10.000 $130=2000.000 $131=2000.000 $132=200.000

If you’re stuck at 9600 baud there is not much you can do unfortunately. The controller will simply never read code fast enough to engrave images at any reasonable speed. You can try using the GRBL-M3 device type in LightBurn, and that will be slightly better, but still pretty terrible. I would try to find out if Bachin has a version of the firmware that uses a faster baud rate.