2021 Omtech 80w Laser not firing

Lightburn Staffer Rick was able to help me when LB couldn’t find my laser. He suggested the simple project of the nametag on the LB site. I have been going thru that very slowly and was ready to engrave it today.
My laser will not fire though. I noticed that my digital milliamp meter isn’t coming on either. I used LB and autofocused Z. I also Framed it to make sure it would fit on the scrap board I was using. I started the project and it moved back and forth but nothing was being engraved. I also tried the OMTech Test file from in the controller…it also just moves back and forth and doesn’t engrave. Please tell me my brand new laser isn’t dead already.
Setting for the Lightburn Nametag project are:
Fill layer—200mm/sec and 20% Max power 14% Min power.
Line layer—200mm/sec 20% Max & Min power

I searched thru a bunch of topics…but couldn’t find anything that helped my issued.
Help–again…
thanks

Hello,
Not that this may be it, is the laser power turned on the machine? Most machines either have a toggle switch , key or door switch that needs to be turn on in order to activate the power to the tube. I know because I have forgotten to turn mine on before. Just a suggestion.
Cheers

Thanks for your reply David. But no, that’s not it. I turn the chiller on…wait a few moments till its Normal…then turn the key and press the power button. The machine comes on…homes out…and comes back to where I left X and Y. LB files don’t burn…OMtech files dont burn. The laser moves…and the red dot is displayed on the part…but no engraving is being done.
It has something to do with that digital miliiamp meter…its not coming on…and it use to come on immediately after pushing power button…

I did some more troubleshooting on my own and believe it may be the digital power supply for the laser. Everything is nice and tight connections on the machine. I noticed that since the digital display isn’t working, something must be up with the Digital laser power supply. I noticed that the fan isn’t running when the key is on for the laser. And since the display is connected via ethernet cable…if the Digital laser power supply isn’t working properly, it’s not going to display the signal. I contacted Omtech thru amazon and awaiting their reply. I will keep yall updated.

Hey Adam…

Some quick troubleshooting… Do you have a volt meter?
I had the same machine, and while they’re an awesome machine, Myself and others have had to do some “clean up”, as they seem to be assembled By Drunken Monkeys or something.

Check the input power to the power supply. If it’s good, then Obviously, you have a power supply problem… If there is no AC even getting to the input of the power supply, chances are, a wire simply fell off of the switch.

The wire bundles tend to be very short, and I do not think China owns a proper screwdriver, as On My machine, when I took the E-Stop button out to check the power leads, they just pulled right out. They were not even tightened…I went through the whole machine, and like half of My screws were stripped, and several crimps just pulled off of the wire with little to no force required.

If it was working before, a loose connection could have simply arced enough times to break continuity.

Tech support is pretty lame. Go through the machine yourself, and familiarize yourself, so when something happens down the road, you have an idea of where to look.

The reason I suspect a bum connection, is that the LCD and fan are on the input side of the power supply. Normally, they will still work, but the output stage will be bad, when a Power supply gives up the ghost. The fact that you have no activity on the unit at all, leads me to suspect that you will not find AC power coming in.

The built in power outlets are quite often the culprit. on any machine… they’re the multi-functional 220 / 110 outlets. they have a bad habit of simply melting, as the manufacturers often use them as a splice block, and they act like a fuse.

You should have power to your 12 or 24V power supply, and to the laser Power supply, and the rear outlets… Find out where they all tie together, and I bet you find your problem.

I hope it’s an easy fix, and not a totally Dead PS. the waiting for stuff from China right now suuuuucks!

Oh! Also, check the 110V / 220V switch on the laser power supply if it has one. It could have been not fully switched. if it’s in 220V mode, you could have toasted a couple ceramic capacitors on the board. If that’s the case, don’t admit it to the manufacturer. Just play dumb. Keep your story short and sweet. It was working, you turned it off. When you turned it back on again, it didn’t work. end of story. They love to try to find a way to blame you. Don’t give them ammo. :+1:t3:

Hey Adam,

This has happened to me before and it could be a possibility causing your issue, I’ve had the door open switch that makes sure the front cover is closed not click when the door is closed and I had to bend the lever up slightly so that it would activate the switch when closing the lid

Thanks guys…I looked over it for loose screws…but everything looked pretty good.
I had to make a youtube video for OMtech. I got an email today that Amazon removed the link​:rage::rage:.
Anyways I replied back with the name of the title. If yall wanna see it its:
BROKEN 2021 OMtech 80w laser (READ DESCRIPTION)

I’ll try to do some more self diagnostic with the volt meter…but I’m 99% sure the laser power supply is dead.

I really appreciate all the help and this community has been great!

Well…laser is back firing. I did 2 omtech tests files back to back! Only issue I’m having now is the door switch thing isn’t working (yellow light). When I had the door open on 1st day…yellow light would come on…now it’s not. I DID find a loose connection on the left which I tightened. It’s a cable that has a metal end that’s threaded…that goes thru the hole to see if the door is down. The other side of the machine has a orange yellow “rubber” piece by the door lid. I even looked on youtube as bearded builds has the same laser as me, 80w. His looks the same by having the threaded metal piece on the left and orange piece on the right of the door. But the light doesn’t come on when the door is open. This is more of something that should work that isn’t, and I paid good money for everything to work than anything else. I’m smart enough to know when the lid is open…lol

I did some nametag testing today from that tutorial.
I burned the name “Lightburn” with the offset. I tried just a few different settings for power and speed.

Correct me if I’m wrong…but should more power or slower speed have a darker burn image?
I started with 200mm/ sec speed. And 20 max power for both fill and cut

Then I tried 20 power and slowed it down to 175 mm/sec

Then I tried 40 power and 200 mm/sec

I still have a lot to learn!

Use both plugs included with laser. One is the laser only and other us machine.

Yeah…I had both plugs plugged up…but the laser one wasn’t in all the way.

It’s lasering now…but the yellow door light isn’t working. Found a loose connection and tightened it…but no yellow light yet when door is open. I don’t know what else to check on that.

well thats good to hear! The door alarm was not connected on mine either, on left side. But my light button sensor is working on the right and on top, was told not a huge issue…just do not open while lasering! lol My issue is that LightBurn 09.24 is not connecting to the laser Ruida controller. Read that i can install 09.20 to solve problem but I do not want to uninstall and not have the key code to reinstall the other! Your LightBurn is connecting to your Ruida controller?

What OS (and OS version number) are you using? If windows, did you install the driver on the last page of the LightBurn setup? You may need to do that to talk to that Ruida controller.

You can roll back to a previous version and not lose the seat allocated. These are separate things, managed differently and should not cause you an issue.

GOT IT DONE! Thank you for help.