$30 & LightBurn Setting work... when they don't match. Advice?

Hi, I am having a bug with getting my laser to work at 100%

My default $30=255

When using LaserGRBL I have set & used $30=1000 without a problem

When I came to Lightburn I kept the $30=1000 and set LightBurn Device Settings S-value max to 1000. This hardly burnt my wood with a filled box at 100%

I changed both to 255, like my defualt, and the same happened.

Now if I cange my CNC to $30=255 and LB to 1000 and this produces the results I expect at 100% burn.

Can anyone explain this and is this safe to use?

(Using GRBL 1.1.7 firmware on my CNC machine)

You’re trying to move faster than the machine actually can, and so it’s lowering the power instead:
Read here: Configuring a 3018 CNC (or other CNC-based laser) for use with LightBurn
Pay attention to the part under the speed / power graph where it talks about variable power.

Yes this seems to change the game.

So my $110/$111 have to be set to 1500 (My machine defualt) to get the results I expect.

I raised my $110/$111 to 3000 and toled LB to go at a speed of 3000 but as you say it seems to cut the power in half. This means I can’t overwrite this max speed of 1500, is this some form of built in or hardware setting?

Thanks for your help on all this, it really makes this hobby much more pleasent for me and helps keep my motivation up!

What are your $100 and $101 settings? If they’re quite high (800 or more) that would be the reason. 8-bit GRBL is only capable of sending motor steps at a max of 30,000 per second.

If you have a machine that requires 800 steps to move 1mm, that would mean you couldn’t move the machine faster than 37.5mm/sec (2250 mm/min) before GRBL simply locked up, incapable of sending more pulses. If the machine uses 1600 steps per mm, as some do, that cuts that maximum in half.

My $100/$101 are 400.

I litterally just cklicked what you said about the 3000 and GRBL.

So my machine can go at a max of 75mm/sec (4500 mm/min) so actually I should of been able to do the 3000 I programed before?

$0=10
$1=25
$2=0
$3=2
$4=0
$5=0
$6=0
$10=3
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=1
$100=400.000
$101=400.000
$102=400.000
$110=1500.000
$111=1500.000
$112=1500.000
$120=50.000
$121=50.000
$122=10.000
$130=300.000
$131=180.000
$132=200.000

If your steps/mm are 400, then yes, you should be able to go the speed you’re saying.

Your accelerations are set pretty low - that number is mm/sec per second, so it will take your machine two seconds to accelerate to 100mm/sec.

Were you burning an image, or do you mean this was just a filled rectangle? I would expect that to work, and be no different than in LaserGRBL, though the acceleration being low means that in ‘Variable Power’ mode may start with less power until it gets up to speed. (LightBurn uses variable power mode by default) . Increasing the acceleration might help.

Amazing! things are woking super smooth now!

I will have to play around with the speed and power setting to give me the best outcome when doing images now. But at least I know it’s all working! Happy dance

What values would you reccomended for $120/$121 & Speed as a base for me, I will then play around with values around those marks to see what works best for me.

I am woking on a 3018 machine and I suppose the stuff I will work on will be around the 50-100mm size to start with. My laser is 5500mw in power.

I really can’t thank you enough for the amount of help you have provided me, and probaly saved so much time in my life waiting for the laser to burn at 1/4 the speed its capable of haha

For speed, the 3000 you had originally is likely fine. For acceleration, start by just doubling the numbers you have and try that. Keep doing that until it fails (skips), then back off to the last one that worked.

Brilliant. I will start running some test on this. Have a good evening Oz its been a pleasure.