50w CO2 firing when framing






CO2 50w Vevor

I’ve seen threads on here where others have had trouble with the laser firing when using “frame” to centre work.

I just replaced the power supply unit, which was a simple case of unplugging two green connectors and attaching the power output cable to the laser tube. All done without any problems.

I now find that when I frame the work the laser fires and marks the frame on the workpiece! It also marks a trail between individual cuts.

I’ve tried to understand all the solutions mentioned before, but I’m still stuck.

There used to be an option in Device Settings to switch on (or off) the “enable laser fire button” which also had the option to change the power setting of this “pulse”.

It seems the updated versions do not allow this on DSP controllers (CO2 laser), for safety reasons?

How do I fix this? It’s driving me mad :crazy_face:

I’ve attached device settings, PC spec and a photo of the problem.

When that happened to the power supply in my CO₂ laser, OMTech sent me a new power supply:

IMO you just got a dud power supply.

That blog post gives a few more details that you can test, including whether the laser fires while framing with the cabinet lid up. If that happens, it’s definitely a bad power supply.

However, one more thing to check: make sure the wire carrying the L-ON signal from the controller to the power supply is firmly connected at both ends and is not shorted to GND. This is easier if you have a voltmeter: the signal should be around 5 V with the laser beam off and 0 V with it on.

Did you sort out the failure mode in which this happens? I assume controller is not involved since it’s not commanding the LPS on. Did this require motion from the steppers? Or was the laser just consistently firing all the time?

I’m very not comfortable with the laser failing unsafe. That seems a bad design.

Are the inputs and outputs the exact same on both power supplies?

Also, what prompted the initial replacement of the LPS?

I got there first! :grin:

The HV power supply had only two signal inputs as they built it:

  • IN = PWM control over how much tube current
  • L = when to fire the laser (active low)

AFAICT, the optoisolator on the L signal failed hot, so that the laser was always ready to fire whenever the IN PWM signal was non-zero. The controller seems to set a low PWM value when framing (over which LightBurn has no control), so the laser fired even though the L signal was inactive.

Aaaaand, because OMTech built it with the power supply’s P input jumpered to ground, it would fire even with no water flow.

I ran the lid interlock signal to the replacement supply’s P input, in the hope that it would not fire with the lid open, even if the L input failed the same way again:

Which helps explain why I’m such a bore about eye protection …

I wonder if this is intentional or potentially just poorly isolated.

You have got to be kidding me… :face_vomiting: I need to revisit this on mine but I’m fairly certain mine wasn’t wired that way.

Nice. Unless this also fails unsafe in some way…

Interesting… never thought to even look at it when I was framing :grimacing:


Many lps have an H or TH input, which is an inverted L enable.

This is used in many K40 types and can be useful if you have something that outputs a pwm signal to control when it lases.


I configure and use mine the way it was designed. The water protect is handled by the Ruida. The reason behind this is simple, no matter what, you are depending on the electronics to work… if it fails from a power outage the Ruida can recover on power up… if P input goes inactive connected to the lps, the controller has no knowledge of it and continues…

As an operator it’s up to you to know how to handle the equipment. You should never be in the path of anything that can hurt you without disabling it’s power source…

I only use Door Protect on my Ruida and the chiller is connected to it… I just have to know if the controller says door protect error, that it’s the chiller… The WP1 input failed to read…

You could see the led indicate active, but the Z/U → Diagnosis did not show it had become active.


I don’t use door protect on my machine, because it can’t move air correctly with the door closed… it’s open at an inch. Sometimes run it with the door open, especially with mugs and such.


A regular voltmeter of multimeter is worth it’s weight in gold… they can be used everywhere…

I agree with @berainlb question of why did you need to replace the lps?

Good luck

:smile_cat:

Thanks for all your responses.
I changed the power supply because my laser stopped working, I first tried changing the tube for a spare (which I always carry) but this made no difference so I ordered a replacement power supply from Vevor.
An easy swop-out, just to green plugs from the controller and connect the output cable to the tube.
What can possibly go wrong?
As a matter of interest the laser fires when framing even with the lid open. So yes, I believe I’ve been sent a dud.
You mention PWM settings etc, where do I see these? And there’s a mention of performing diagnostics. Can you explain in simple terms please. Again thanks in advance

This is more of a technical term… the actual hardware generates a 50% pwm when you set the power to 50%.

This 50% pwm tells the lps to generate 50% power on your tube…

Make sense?

Most users are oblivious of this and just call it power or percentage power.

:smile_cat:

That is absolutely conclusive evidence of a bad supply.

I rest my case. :man_shrugging:

Yes sir @ednisley ESQ… we’ll see if there is a rebuttal or appeal… :crazy_face:

:smile_cat:

In this day & age, one can expect slow walking: supply chain issues, don’cha know?

Hi everyone, a final update on the problem.

After 2 weeks of messaging back and forth, (excessive demands for photos, videos etc). I ordered a second power supply unit, just to see.
I swapped this out with the problem one, you guessed it, and thank you for saying it in the first place!, the new one worked fine.
Another week down the line the supplier has finally given in and is sending me a replacement.
Thanks again for all your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.