50WJPT Fiber no longer connecting to computer. USB Error

Hey, I’ve been a CO2 laser user now for just over a year, and recently received my 50WJPT Fiber… All was going great until today. Long story short, a customer happened to somehow disconnect the USB cable, or step on it, or something as the laser was running a project as he was leaving. I went back to the machine and just assumed it was complete and went to load the next project and Lightburn said that the Laser was disconnected… So, I unplugged the USB and reconnected it and I got the following error:

Windows has stopped this device because it has reported problems. (Code 43)
A request for the USB device descriptor failed.

Having seen that before with the CO2, I re-ran the setup to reinstall the drivers and that didn’t work. I removed the cables in question and replaced with different ones, and that didn’t work… I uninstalled, reinstalled Lightburn, uninstalled the drivers, ran windows update, restarted a million times and that didn’t work… So, I opened up the laser, and plugged a USB-Printer cable directly to the controller board, and that didn’t work… So now I’m 100% stumped. I’ve tried every USB port on this computer, I’ve tried absolutely everything I can think of and I cannot get the machine to speak to the computer. I don’t have a laptop to try so I’m gonna have to figure this out, but I need some assistance I think…

Can anyone point me in the right direction?

thanks in advance

Sounds stupid but have you tried a different cable? and another usb input? It could be that the port or the wire contacts have suffered some damage in that accident.
Try another usb device and see if the computer usb port is ok.
good luck

Yes, I’ve tried running direct to the controller with a new cable. I’ve tried all the USB ports as well. Every time it connects, it tells me that the last item connected by USB has malfunctioned and windows does not recognize it.

pity, …but at least it’s tested

Yeah, it doesn’t make sense. . My wife has ab older laptop that may not even run, but it I can get the laptop itself working, I’ll see if it can communicate with the laser as that’s more or less my last option

…as long as it can handle Windows 7 there is a good chance.
What about a mouse or keyboard?, can they be used to “test” the usb port on the PC?

Well, I now have no idea what the hell the issue is… I went out and purchased a new laptop and I get the exact same error when connecting the USB cable… “The last USB device connected has malfunctioned”…

I don’t know whether something shorted out and fried the controller or what… I was hoping that there was a way to reset the BJJCZ controller, but I’ve yet to find that information anywhere either.

I’m sorry to hear that. It looks like the only options left are to contact the vendor to ask for help (within the warranty period?) or at least for technical assistance.

Hi
I also had problems with a stable USB connection at the beginning. The connection was constantly being re-established and then severed again shortly afterwards. Cables and plugs brought no solution. Then I opened the laser housing - but first unplugged it - . I then reinstalled the controller board galvanically separated from the bracket. To do this, I reinstalled the controller with plastic screws and spacers so that there is no conductive connection between the controller and the bracket. That solved the problem in my case.

1 Like

Thanks, I’ll have to have a look at that if this new cable doesn’t work when it arrives. I only received the machine 2 weeks ago, so it’s absolutely within the warranty period, but still a PITA nonetheless.