$58 laser looking good and cool

With proper settings it homes as expected, then paused for second and then moves negative, that hits hard stop right away.

Well, I was not able to overcome it. Not with that JL3 firmware. If you can - let me know. And I’ve tried. I vent as far as flipping whole frame, milling hole for X home on left plate of gantry, swapping all left to right pretty much like JL3, and I also found that moving Y switch to the left will cause lever to flip, that require change of switch holder, so I’ve printed one. I had both switches at 0:0. I can home. then it moves Y negative. moving that Y switch to far end not good either ans there is not enough length.

As I’ve mentioned, I’m pretty certain that Homing Cycle has hard coded move negative after switch homing complete. There is no settings that I can find for it.

After all I went through with homing - I give up for now and rather focus on recompiling custom from GIT. For now: homing cycle disabled and I home by hand. Easy.

JL3 has home switches at x=0; y=far+. So after finding Y far, it moves to Y=0. That move is too much for any dimension of JL1.
JL1 had home switches at x= far+, Y=0.

This firmware BIN file is 39K. This is generally in line with most GRBL firmware, Atmel included.

STM32 used here is the same as Blue Pill board. Most specified as 64K, but the fact is that most of these are 128K. Either way, plenty of flash to add custom code for anything.

I do non think that recompiling need much or any customization. Pointer can be MIST or FLOOD.
The only customization to GIT I can think of is dual serial port.
Just need to define pins and compile.

Doug, You are right, it certainly looks like STLink port.
I do have STLink but did not pay attention.

Regardless, I’ve tried to flash that BIN to BluePill, through STLink, not able to see any talk on serial.

If you get it - interesting to try to pull original firmware off, just to have it, for no reason at all, as an academic exercise.

Are you skilled enough to recompile from some of GIT sources? I can get pins mapped.

1 Like

Picked up a similar (looks the same) for 10 bucks more… Ordered it, will be here Monday…

@rcline → I have the spousal units approval… :crazy_face:


1 Like

did you get one of these things just to tinker with? LOL

caught me :crazy_face:

That will make the 4th one that’s grbl… can’t hardly build one for that…

I’ve got my Neje 30 watt module around here somewhere… Maybe it will mount on it… lol


go for it, you can make it work. ---- I’m thinking about ordering an ortur master, (not 2 or pro) controller board and mount that on the cenoz. May have to swap pins around, maybe hustle up some different plugs.
But I think it should work? I found the board that I wanted, a real ortur board for only $9.99 and there was only $70.75 in shipping. LOL

I did the same a month ago, set me back $69. I see the price has gone up- probably due to popularity! I’ve been following this thread and it got my curiousity up plus I’ve been wanting to give FluidNC a try. This will be a nice little test bed once I change out the controller I think.
The engraver as received does work and does an OK job with its funky limited software. I found I had to reassemble all 3 carriages as they were in almost unusable condition, very loose hardware and some with locked up wheels! Surprising it could move at all, but it did! Easy fix, just something for you to look forward to. I have a MakerBase board here so I’ll get it running with that first then give FluidNC a try. Yeah, I am a tinkerer.

Thanks for the heads up, but I know it’s ‘cheap’, that’s why I bought it :crazy_face:

I don’t have windows so I’ll have to figure out something that will run Lightburn on my Ubuntu machine. I will probably have to ‘steal’ the wifes windows box to read the configuration off it.

I dread dealing with windows worse that what issues I’m going to run into installing limit switches…

I have a functional hall limit switch that I use on my other machines. Should be an easy addition.

I have a couple boards around, not sure what’s even in/on the thing or what firmware…

I got kind of lost with all the different types of boards…

Is this the board you refer to?

I could spend 5 times what it cost and put a Ruida a couple of motor drivers and … lol

On my China Blue, the motors go pretty warm or hot… It was set to full current for hold and 2 times the current limit of the motors… Fixed that… it cost me $2k and it’s configuration was hosed. One of the 3018’s I bought with limit switches. The Z axes went down when it booted… :frowning:

I’m suspicious it’s not configure right when I purchased it and I’m even more suspicious by the time it ends up on my doorstep…

Photo looks like post 27… good thing they use ‘imported chips and high-precision algorithms’ … :crazy_face:

Screenshot from 2022-08-06 06-44-51


1 Like

Yup, thats the board I have though I don’t necessarily recommend it. This morning is the first time I had a chance to get it hooked up and give it a run…not too good. It’s advertised as set up for laser with the right firmware pre loaded. In my case, not true! I re flashed it with the supposed correct firmware which changed the display but nothing for the operational side. I gave up and loaded FluidNC on it so now I have something else to learn. Bare board sitting here talking to LightBurn so that’s a plus. I’ll get it set up on my test bed ($69 wonder) and give it a go in the near future here.
Steve …

Did you save the configuration from the first and load it into the new one?

I assume so, but just thought I’d ask…

Where did you find the ‘new’ firmware from them and where did you get the new firmware you are trying to use now. Did you post links to them ‘back there’, somewhere in the 50 some entries ?

I assume Lightburn wouldn’t even talk to it…?

Mine is supposed to be here Monday.


slight change of subject here, just for a second. Remember that 58$ laser that I gave up on and wrote it off as getting burned. For the fun of it I did a track # search again and today it says that the package will be turned over to usps in about 2 days. Like I’m really going to bet on that!

I looked at that MKS-DLC32. I getting one for sure to mount on my cenoz. Maybe two !
Jack – I run ubuntu on my laptop. Every time I try to run something on it, a window pops up and says I have to upgrade. I downloaded the latest version, but I can’t get it to install.

The Lightburn license is only valid for updates/upgrades until it expires. You can continue to run the one you are already using, but if it’s expired, you cannot update to a more current version…
You have to renew your subscription…

Should do it a couple months prior and you get extra ‘time’…

I assume that’s it…?

I don’t know how you ‘install’ on your Ubuntu box… I have my lightburn folder in my root directory “/home/jack/LightBurn” with the proper desktop file an upgrade is relatively simple.

  1. rename the original LightBurn directory to something else - for a backup. I just append ‘-x’ to the name…
  2. Click to open the .7z file and navigate to the directory above where you want it, in my case it’s /home/, highlight ‘your home’ and extract.

Just click your Lightburn icon and you should be in like flint…


I’m not talking about Light Burn. I have Linux Ubuntu 9 year old version. I downloaded the latest update to it. But I can’t get it to install. Every time it gets half way through, it crashes. If I can get to update, it should have problem with light burn. I hope !!

When did you last update it?

Sometimes it doesn’t work too well if you miss a bunch of updates… at least IMHO…

Might have to either find out how to upgrade it gradually or worst case a backup of your data and re load it… I cringe at that though…

Might try googling it…


Update it a little at a time, oh boy! I remember when I got the update about a year ago, I lost count of the number of updates they had over the last 9 years. I think my ubuntu starts out as version 0. something. LOL

jack@Kilo:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.4 LTS
Release: 20.04
Codename: focal


Yes I Did! Thank you.

See this thread: [DLC32 M4 does not work]

That was my problem… M4 would crash it. I flashed with the firmware that was given but didnt fix my problem. Trying to flash back the flash program could no longer sync with the board. Being short on patience I figured it’s time to give FluidNC a shot. That loaded easy enough and communicates fine with LightBurn. I’m running the board here on my desk with nothing connected, homing disabled, watching the lights flash as it cruises thru a job. I’ll get it hooked up to a ‘real machine’ tomorrow.

Hope you have better luck. I’m not disappointed with my board, I think it will do fine with FluidNC. Yet another adventure!

Would a terminal talk to the board with the original firmware?

I can get a grbl board for about $30 bucks… from amazon. The only real drawback I know of is the pwm is only 8 bits. I can get along with that…

This looks much like a couple of them I use…

I have a couple of Woodpecker control board that has it’s limit switches marked X, Y and Z but in reality it turned out to be Z, Y and X… Right to left… That stumped me for a while…


Really as far as commercial hobbyist boards are concerned the MKS DLC32 is really one of the best options. I suspect the issuse @papa.zed saw was something specific to his setup. There are plenty of others here running that board without issue on both diode and co2 lasers.

While I’m sure this will work I’m not sure it will scratch the tinkering itch you’re after. These are going to be very similar boards to what you already have.

Have you considering supporting some of the more interesting homebrew boards? Perhaps something built on Raspberry Pi Pico or Teensy controllers?

grblHAL BoB Unkit for Teensy 4.1. - T41U5XBB from Brookwood Design on Tindie

PicoCNC - a grblHAL breakout board. · Discussion #3 · grblHAL/RP2040 · GitHub

These will be much more cutting edge and experimental and a good way to move the community forward.