$79 Cenoz laser engraver on Amazon... any good?

Typically no. They should be written immediately if allowed.

I got through this confusion and realized that board constantly tripping into safety lock. This is due to out or range positions and home/end sensors.
Find my other thread with GRBL settings dump. Set it up and it will run smooth. No home cycle though.

Can you post them again please?

With original boot loader, that firmware can load at different address and may start from boot loader then just jump to that firmware address. We may never know, because that firmware is locked. I know for sure that it does not run from default address.

That 0x8000000 point is the beginning of the flash and default execution start with boot pins default configuration. As that firmware does not run from default flash beginning - there is very little hope to actually make it run at all, not without original boot loader or unlocked firmware.

The best shot we have is to recompile from some source.

Me too already got DLC32 and already printed box case for it. It runs just fine tethered. I got big screen (3.5") and realized that I probably will never use it. If I would need screen again - probably will get smaller one. More likely - no screen at all.

With that - It is fun challenge to make firmware for original board. I will work on it in spare time. I believe I’m making progress with that hardware timer relocation (TIM1_CH2N) to make PWM proper.
That STM32 is very different from Atmel. That HAL CubeMX spitting a lot of code that to me is very difficult to manually sort through.
I;ve tried to find another source, like to Atollic, but none that I’ve tried compiled cleanly, and cleaning these warnings and errors is beyond my intentions.
So, for a while I will stay with that Embitz compiler and try to generate HAL config for that code with CubeMX.

Any volunteers to star shared project on GIT?

I need help to figure out how to move TIM1 from A8 to B0. This is done through “partial remap” but so far I see no PWM on B0. Requires duplication of all registers for CH2 from CH1 and then do proper timer output configuration on B0. That pin relocation also forces to use CH2 of TIM1, instead of CH1.

The only way I can upload to the controller is via the st-link hardware. You can’t write to it or read it without wiping the firmware. That’s security of the micro…

With st-link, I’m not using a boot loader, so I think discussion is moot, unless the boot loader handles the serial communications port, doubtful.

I’d love to load your binary and see if it will talk, that would give me some satisfaction.

The IDE you use is only available on a Windows platform, from what I can tell. I have the ‘cube’ programmer and their IDE (Eclipse, I think) on my Linux machine, so it would be nice if I could get it to compile…


Just adjusted my settings to match lsrsal.
turned the machine and Light burn on and off a few times and the setting seem to be holding.
Everything works perfectly and currently running a tile.
Thank you Sal.

1 Like

Loads ok at the 0x8000000 address, but Lightburn won’t connect.

The same message

Waiting for connection...
Port failed to open - already in use?

That’s I’ve been getting… Thanks for uploading it… Might want to just delete that post before someone loads it while in hua mode.


I’ve gotten that message before too.
Found that I just had to choose another com port on the laser tab.

That is not firmware, that is port selection.

Don’t follow you…


In the application, select com port. If not sure: pull USB out, check what ports available. Plugin back - see which one appeared new and select to be use by the app.

I know what com port it is, that’s not in question.


OK. But apparently application cannot open available port. Some other software running?
When I’ve tested it - I forgot to plugin switch. Board has power jack but without switch - micro gets no power. You will see port as it gets power form USB, but not the micro.

I double check the power. It’s off when I program it, as the st-link hardware has a small supply of 5V. I’m sure the HL-340 usb → serial is getting power via usb. It’s also the only thing I have that reports that way… Thanks for the thought…

When I got this machine, I got the same response that I have now. I could not talk to the port on the board with any standard dumb terminal. It wouldn’t even ID itself when it booted…

I ran their software on my wifes computer and it ran fine.

I run Linux and it doesn’t really have the ‘driver’ problems that windows has. Mine is setup to idVendor=1a86, idProduct=7523 via UDEV and assign it to /dev/ttyUSB* where * is a number that can change.

The only USB anything in /dev/ is the one I’m selecting (or Lightburn selects via ‘auto’). So I think I’m on the right port.

If you see an issue, please clarify, a good reason is all I need… I wish I was infallible… :crazy_face:


-At this point it appeared that you are confident that driver is setup. (or is it?)
-You also verified that your wife’s Windows PC is able to talk to it, so hardware is functional. As a fact you can repeat this test with my test HEX on you wife’s PC. This one definitely talks. 115200b, 8n1,none.
-Post here your DMESG, maybe we can see something. Linux may see USB ID, does not mean it did load proper driver.
-Even if port is properly setup on your PC - some other application may take over. Run command to check, for example:devices - How to find which serial port is in use? - Unix & Linux Stack Exchange
-run “ls /dev/ttyUSB*” post output here.

Just noticed, that STLink interface is 3.3V. You should wire 3.3V, not 5V. Now there is a chance that board is fried.
Can you program it? What application you are using? Does it report that flash erased and programmed OK?

You’re right, it’s 3.3V, not used to that… I set it correctly… thanks…

How could the USB device tell me what it is if it couldn’t communicate with that port?

Bus 003 Device 011: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

Means the hardware at the low level is talking enough to get the ID off the device.

I have nothing plugged into any of the hubs except my keyboard, mouse, Wacom tablet and this.

jack@Kilo:~$ fuser /dev/ttyUSB2
jack@Kilo:~$ ls -l /dev/tty[UA]*
crw-rw----+ 1 root dialout 188, 2 Aug 20 11:30 /dev/ttyUSB2

Doesn’t appear anyone has it…


We can try to troubleshoot your Linux, but this is about JL1, right? Have you tried again wife’s windows PC with terminal? If you had success running original software - meaning driver is definitely setup: connect USB, 12V and power switch, open terminal. Toggle power switch. You should see GRBL boot message.

You did not confirm if you can flash firmware again, my test file, with no errors. Please do and confirm.
I test file I give you on actual JL1 board and it talks GRBL no problem. (though nothing else).