$79 Cenoz laser engraver on Amazon... any good?

What cn the original board do? (I just ordered one as well)/

Jack, it was probably your comment I was referring to… I just couldn’t remember where I’d seen it. Thank you, and I agree with you completely. I’ve since requested the Grbl firmware upgrade from Wainlux for the JL1 board. Hopefully they’ll respond.

@LsrSal posted the firmware files if you hadn’t seen them. Check it out:

1 Like

Thank you. I’ll check it out.

In the end, Lightburn says ‘ready’ but the command window shows it’s waiting on a connection.

The flash operation, just clicked the upgrade, got a green bar then back to the ‘upgrade’ screen.?

Upgrade.exe do a similar job for you or was it more verbose?

Can’t seem to connect but the status in the laser windows says ‘ready’…

Screenshot from 2022-08-14 08-09-18

Wonder if the flash failed? Tried to re-run upgrade.exe but complains of ‘no device found’

EDIT - it will find the device, but the progress bar makes about 80% and it’s back to where you click ‘upgrade’.

In the move window, nothing responds, as was expected.


Some progress… successfully flashed the JL1 board with Grbl 1.1f (@LsrSal’s ROM.bin file). I use Chromebook/Lightburn almost exclusively but decided to fire up my Win7 machine for the first time in a couple of years. It took a while to update wifi and log into forums. Yuck!

Downloaded @LsrSal’s zipfile and extracted ROM.bin and upgrade.exe files to Desktop. Found instructions from @LsrSal in a different thread to…

  1. Make sure power is off on JL1 board
  2. Make sure upgrade.exe isn’t running
  3. Connect USB cable… computer to JL1
  4. Push and hold button (between the USB and power connectors) on JL1 while powering it on… puts board in upload mode
  5. Execute upgrade.exe

A very simple window pops up with one button and progress bar… apparently just defaults to ROM.bin…

Clicked “start upgrading” button and indeed a green progress bar comes up and completes. No messages, status, nothing… but no error indication either.

Since I had previously swapped out the JL1 with a different Grbl controller, I reconnected the JL1 board back up to the laser engraver. Moved over to Chromebook and Lightburn… connected USB and got indication that a USB device was detected and connected to Linux side. In LB I was able to connect and console indicated GRBL 1.1f. It acted a bit flaky at first and kept locking up until I also connected up the limit switches and adjust some settings. It’s now settled into a predictable state and I’m air-milling now under Lightburn control.

So, it looks as though it’s pretty easy to flash that board with a ROM.bin file and the .exe. Hate to have to fire up Windows but, given the tools I had, I guess that was my only recourse. [I now feel a little “dirty” :upside_down_face:] Given the generic filenames, I had no way at first to know for sure what board that ROM.bin was set up for until I finally tamed the erratic operation…

Screenshot 2022-08-14 10.34.49 PM

The upgrade.exe appears to do what it was supposed to do.

– David

Same thing I had before. The green bar on mine goes to about 80% and that’s where it goes back to ‘start updating’… The green never fills to 100%

I have no issue with soldering stuff, so a header is simple, but I need to know where it is and what the pin out is…


Believe these are the pins for the STLink connector. Circled in red with PCB marked.

Jack, I think I’ve confused the issue, posting to the other thread you’re engaged in with @LsrSal. He asked you about soldering… and you’re last post here seems to be related to his question. I apologize for the confusion I’ve caused. – David

Yea… these two have links that reference each other or something like that…

I’m confused easily, don’ let it keep you up at night :crazy_face:

Still not sure if I flashed it with a known ‘bad’ binary or ?


1 Like

@dkj4linux I curse you! I had to order one too!

Unfortunately I will not be able to play with it for a week or so. My son is getting married this weekend and cutting into my laser time! Oh well.

I am looking forward to making this able to use LB. Wish me luck!!


LOL. In the V1Engineering forum, another place I “inhabit”, a poster just informed me that the price is now $99! I hope that’s not what you paid. Just a couple of days after I ordered mine for $79, they lowered the price to $75… and I’m pretty sure they said “thru August”. I felt good they had created a “special” for those who might want one… and was even considering buying another one :wink:

The original Cenoz branded offering is indeed $99.99 but there are a couple of other listings for what looks like the same laser for a $75 and $79.99 respectively.

Amazon.com: Upgrade 3W Engraving Machine, Yofuly 3000mW Mini Desktop Engraver DIY Printer CNC Wood Router, Working Area 200mm x290mm
Amazon.com: Titoe 3000mw Mini Engraving Machine Desktop Engraver Printer for DIY, Logo Mark(Working Area:290X220mm)

1 Like

I paid $79.00. I had to wait because I had a $25 Amazon gift card that I wanted to apply to it and did not have it available when it was $75. I did try to see if there was a cheaper price but unfortunately I did not see the $75 one. It will be interesting to see how long it stays cheap

1 Like

I found a different listing for $59 back when this first came up. I’m sure these will just make the rounds for a while with fluctuations in price. Looks like this has had some pretty severe price swings the last few months.


I believe that was for a unit that was half the size. I could be mistaken though.

Like @jkwilborn said… just think of how many of these things they could sell if they ditched the proprietary firmware and just put GRBL on them. Wouldn’t cost them anything and instant LightBurn compatibility… :wink:

1 Like

I have a 2.5 watt JTEC laser that I was going to mount to my 3040 unit. But at this price I couldn’t pass it up.

1 Like

I must have misremembered the price. I think it was $69 and the size was 200x290 which I think is the same as the ones being discussed here.

1 Like

@berainlb I believe you are correct.

1 Like