9.13 focus test broken

Hi,

Just did a focus test with 9.13. It frames OK, but then goes to run outside of the frame area.
I saved it as an RD file and imported that into LB. Frames and burns OK but all the settings are broken. Seems to use random power and speed settings. Need to manually readjust.

Joel

Importing an RD file just imports the vectors, not the settings, so that isn’t surprising.

Do you have Rotary enabled or anything strange like that, maybe? Was the machine homed when you started it up? If not, that would do it.

Hi,

Everything was set up properly. I did re home everything after the first failed attempt. I went back to 9.11 and it works fine.

I do not have a rotary, so that’s not the issue.

The focus test should run in the exact middle of the machine. Where did it try to go?

Hi Oz,

This would be contrary to how 9.11 works. It should cut where I set the origin, which is what 9.11 does.
Also, it should cut where it frames not somewhere else. 9.13 frames fine, but then cuts somewhere else.

Something has changed in the way 9.13 behaves.

No, actually, 0.9.11 cut in the middle of the page too - at least, it’s supposed to. It creates the focus test job centered in the page and automatically sets the mode switch to ‘Absolute Coords’ before it sends the job, then puts it back to whatever it was when it’s finished.

Not how it works for me. I just did a test where I moved the origin off to a corner. The focus test framed there and burned there.

Now, if you are forcing it ( really shouldn’t ) to do the focus test in the center, you should also frame there. Framing in one place and burning in another probably doesn’t make sense.

From my POV, the focus test origin should be the upper right corner of the frame and should start with that point being the machine origin, just like doing any other laser job.

If you insist on forcing the location, would be good if framing and burning start at the same place. For now, I will just stick with 9.11, it is working as I expect it to.

You misunderstood - It’s supposed to both cut and frame in the center of the workspace. If it doesn’t, that’s a bug, and wasn’t intended. (It’s also a very new feature)

And “the upper right corner” is far from standard - lots of people use center origin, lower-left, etc. I’d be OK with not overriding the chosen setting, but I’m not forcing it to a different arbitrary choice.

I’m not sure how all controllers work, I have used the LO T9 and currently use the Ruida 6445G. The way I work is I put my work piece on the table ( usually centered ) I move the laser head to the upper ( far ) right corner of the work piece and then hit set origin. That’s where I expect the job to start cutting. My machines home is the far upper right corner of the machine. I have the controller set up to use the user origin to start a job.

With 9.11 the focus test works this way for me, where ever I set my user origin is where it frames and cuts the test.

9.13 frames where I set the user origin but then moves away to do the actual cut ( looks close enough to be the center of the machine ).

The behavior in 9.11 is what I would prefer whether that was intentional or not, it works as expected for me.

As far as it being a new feature, I like it. Also, I get that not framing and burning in the same place was not the intended behavior, I was just accentuating the fact it’s not working right.

Thanks
Joel

I’ve altered the code to not override the job origin setting, and use whatever you had when you start the focus test. A decent number of people get confused about how the different origin modes work, so the original thinking was that forcing that setting would be simpler, but we’ll try it this way - it’s probably more flexible with the user setting.

1 Like

Thanks Oz, I think this will work how ever folks have their machine set up. It will just do the test where people are used to setting their work piece.

Joel

1 Like

Was this fixed? I just downloaded 9.13 and Im having the exact same issue joel1 was.

The exact same issue would be that the focus test isn’t going where you think it should on a Trocen controller - you don’t have a Trocen controller, according to your profile, so can you describe what your issue is?

When I frame it will frame out where my origin is set to. When I start it moves to the center of the table to start the focus test.

That is the behavior of 9.13, yes. 0.9.14 will allow you to place it anywhere. Prior to that it was supposed to be absolute only, center of the workspace.

Ok thank you. As Joel had mentioned above, I went back to 9.11 and was able to perform the test at my chosen location.

3018Pro w GRBL Controller here. We do not have limit switches or homing/origin capability. Only options for running Lightburn jobs are to use “Start from: Current Position” in .11 and prior Focus Test always honored this and previewed/framed/burned starting directly from where the laser is positioned. Post .11 it previews correctly, frames correctly, but when run the laser get’s sent off the workspace. I know I’m not on a big boy laser but you do have a large userbase of 3018/diode/grbl users. As always thx Oz for your amazing product.

Hi Oz,

9.14 works fine. I notice that now it starts at the lowest Z offset and works up, also starts at the farthest point from the origin and works back. This would be the same I I have my scan set up when I do an engraving. Not sure if you built this in or if it is settable somewhere, but for me, the focus test is working fine and as expected in 9.14.

Thanks
Joel

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.