9.24 not connecting to my Boss Laser

I have had this issue several version back(I don’t remember which one)before and had to re-install the FTDI drivers to fix my issue. But after upgrading to 9.24 this morning, I could no longer connect to my Boss LS1630 Laser. If I do anything like “Get Position” or try to print I get a communication error. To re-install the FTDI Drivers, I re-installed 9.24 and selected the FTDI drivers that came with the install and that did not help. I then went back to 9.21 and re-installed the 9.21 release and the FTDI drivers in that package and I am back up and running.

I don’t know if it’s the drivers, or the code connecting to the drivers. The com port shows no issues in device manager on my system. I have tried different USB cables, different hubs, and connecting to the PC directly. It had no impact. I can use a USB flash drive to copy my file to and print from there with no issues. I have not connected my USB analyzer to the cable to see what’s going on since I have other things to work on today or I would. :slight_smile:

We have been tracking this issue for a bit but no one on the LB side has been able to reproduce yet. Can you give us details on the Version of control you have, firmware version, what OS you are running etc.

At bootup I get
RDC-V8.01.50
HMI-V4.18.01

Also, since it was a very boring day, I thought I would take a look at the USB traffic and compare the commands being sent to the laser from the 921 and 924 versions and look for differences in behavior. I do this type of work for a living and have the equipment to do it so I thought I was spend an hour doing it. So I hooked my USB Analyzer to the USB bus and compared the two traces between 921 and 924. I have attached the xls file comparing the two.

Without Lightburn loaded, I captured the USB enumeration sequence, then waited a few seconds and then opened lightburn, then waited a few more seconds and did a get position command. You will see a large gap in the time stamps between these steps so you can determine what is occurring.

The first huge difference is in the 924 version. After connecting and starting lightburn and then doing a “Get Position” command, I could see the command on the 921 version, but no command was sent on the USB bus with the 924 version. This tells me that whatever bad command/event that happened, it occurred during the device open sequence. The driver is hung already.

I put the two traces side by side and massaged them some. Comparing the device opening sequence, the differences start after row 721 in the attached spreadsheet. The 924 version issues 5 more commands to the FTDI Driver. The 921 does not issue these 5 commands.

After this, the commands going are occurring with less time between the commands on the the 924 version. There is less delay between back to back commands. From the flow of the traffic, it “feels” like initial device open/configuration done by Lightburn was optimized and performance increased and that is somehow breaking my boss laser.

So the point of failure seems to be in the device opening sequence. The inability to send any commands after this is just a result of the failure.

https://drive.google.com/file/d/1FqCneYaaBh-rToAvRBmd_WMKP2_FH0MI/view?usp=sharing

One other observation. I switched back and forth between 921 and 924 several times while capturing these traces and the pass/fail was 100% consistent. The 921 worked with no issues, the 924 failed all of the time.

BTW, I an running the latest fully patched Windows 64.