A couple of problems with the Linux version

I have been using LightBurn on Manjaro Linux (latest version) and have found two problems that are unrelated.

The first has to do with creating material test libraries. I created a new library for a specific material and saved it. I can load and update it in the material test option and window. But if I go to use the library on for doing a bur test, the library never shows up for use. So I have scanned all the folders under my login and it doesn’t show up anywhere. Does LightBurn use the description for the file name and does it allow spaces or does it replace spaces. It seems to find the library for updating and loading but the library is not seen when attempting to use it.


The librarywindow cannot read the .config folder because it is invisible and LightBurn does not allow invisible folders to be shown. The test material card was saved and underscores replaced the spaces properly, but aside from being able to change the parameters, the data can never be used on Linux. Maybe you should add a choice to preferences for Linux that allows hidden folder to be displayed in the users home folder. This is unique to all Linux versions because Linux handles security much differently. You may also have issues with AppArmor since it allows application specific security access by application. The solution would be to have Lightburn create a folder that is not prefixed with a dot which makes it invisible by default.

Second, I created a design in LightBurn for a logo. It worked fine until I rotated it and then it split a line and left a gap. When I rotated it back to its original position the gap remained. This resulted in wasted material since the gap did not show on the display. But when I did a preview, the gap was visible.

So, I exited LightBurn, and went to inkscape to design the same logo. When I loaded the original SVG exported from lightburn, gap was exported from lightburn. So I created a new file in inkscape designed the same logo and saved it as an SVG. I then imported it into lightburn. This time I copied the original component instead of rotating it and rotated the copied component. The original remained closed, the copied once again had the same break in the same location after it was rotated.

Recently, I had to replace several machines and hard drives, so I no longer have any of the Windows drives that lightburn was installed on. Since those two drives were replaced, data was copied off of them and the drives were wiped before disposing of them. But I did not deactivate the licenses before the drives were wiped. Since those were wiped clean and set to nulls, can the other two licenses be restored, since I can no longer use more than the Linux version without having to deactivate the license. I never have more than one license in actual use at one time and is there a way to remedy this so I can jump between Windows and Linux without deactivating one to use the other.

I do have the design files for the logo that was cutout, but I need to know where the library file used for the materials test is stored on Linux so I can manually retrieve it.

Thank you in advance.

Mine live here…

jack@Kilo:~/mnt/dev-test/cnc/laser/fiber$ find 2>/dev/null ~/ -iregex ".*\.clb$"

How did the library get created somewhere that Lightburn can’t find?

I run Ubuntu, I have no issues with the materials or art library functions.

Distributor ID: Ubuntu
Description: Ubuntu 22.04.2 LTS
Release: 22.04
Codename: jammy

I am running the beta versions, but I’ve never had an issue with either library function.


Go to License Portal and deactivate any activations that you no longer need.

Please note that Ubuntu 18.04 or 20.04 are the only officially supported distros for LightBurn - any other distro, your miles may vary, and we are unable to provide support for those distros.

Well, further investigation reveals these are not Linux related issues. They are UI issues. One was resolved with a change to a parameter. The other is s difference between the Windows registry and the way the Linux paths differ. Thank you for responding.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.