Absolute Coordinates issue in Lightburn (Ortur Laser Master 2 Pro)

I’m very new to laser engraving (just got/built my first laser last week) and I have a feeling this might be a very simple question/issue, but I haven’t found any fix that has worked.

When I hit “Home” in Lightburn, the laser goes to 0,0 but when I use Start From: “Absolute Coordinates” and click “Go To Origin”, it takes the laser to the middle of the table area (to 20cm/20cm). Also, if I use the “Set laser position by clicking on the page”, it is also extremely offset or gives me an warning saying that I’m going outside of the bounds.

Because of this, I have to use Start From: “Current Position” to be able to use the laser. I’ve tried to use the “Clear Origin” and “Set Origin” options, but they don’t appear to make any difference.

Can anyone help me out with this? Thanks!

You likely have an inadvertent offset configured on your laser. Can you do a homing operation then run these commands in Console one at a time? Copy/paste all the results in a reply please.

$I
$$
$#
?

Thank you very much for the quick reply, berainlb! Here are the results of the commands that you gave:

$I

[ORIGIN: China]

[PRODUCER: ORTUR]

[AUTHOR: ORTUR]

[MODEL: Ortur Laser Master 2 Pro S2]

[OLF: 185]

[OLH: OLM_ESP_PRO_V1.2]

[OLM: GENERAL]

[DATE:22:44:33 - Oct 25 2021]

[VER:1.1f(ESP32).20210403:]

[OPT:VNMZHSLW,35,4096,3]

Target buffer size found

ok

$$

$0=5.0

$1=100

$2=0

$3=6

$4=7

$5=7

$6=1

$10=0

$11=0.050

$12=0.002

$13=0

$14=6

$15=0

$16=1

$17=4

$18=0

$19=0

$20=1

$21=1

$22=43

$23=3

$24=600.000

$25=3000.000

$26=100

$27=3.000

$28=0.100

$29=0.0

$30=1000.

$31=0.

$32=1

$33=1000.000

$34=0.000

$35=0.000

$36=100.000

$37=0

$39=1

$40=1

$41=0

$42=1

$43=1

$44=3

$45=4

$46=0

$56=1.000

$57=1800.000

$58=395.000

$59=6000.000

$60=0

$61=0

$62=0

$63=3

$64=1

$65=0

$100=80.000

$101=80.000

$102=2124.000

$110=10200.000

$111=10200.000

$112=600.000

$120=2200.000

$121=1800.000

$122=200.000

$130=400.000

$131=400.000

$132=100.000

$259=0

$260=70

$261=70

$262=320

$263=30

$264=0

$265=50

$266=100

$267=0

$268=0

$269=0

ok

$#

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G59.1:0.000,0.000,0.000]

[G59.2:0.000,0.000,0.000]

[G59.3:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

error:7

EEPROM read failed. Reset and restored to default values.

ok

?

<Idle|WPos:-198.000,-143.000,0.000>

ok

I don’t see an offset established but you’ve got some unusual stuff going on.

Can you confirm that you ran these commands immediately following a homing cycle?

You’re showing negative working coordinates. This shouldn’t be possible if your machine is homing properly and without an offset.

This should be $10=1 or $10=2047 for your system. This sets-up your machine for using machine coordiantes which is generally the right thing for your laser.

Are you issuing a G92 command or somehow resetting your working origin?

Do you have anything setup in Edit->Device Settings->Gcode tab?

I suggest holding off on making any changes until we sort through this otherwise we might get more unpredictable behavior. This should be an easy fix but let’s make sure we’re not missing something.

Thank you, again, for the info! Well honestly, I wouldn’t really even know how to issue a G92 command or anything of the sort! :smile: I don’t think I’m doing anything to reset it - although when testing it, before, I hit the Set Origin button with the laser at different locations. I’m completely new to all of this…but that isn’t to say that I haven’t screwed something up. I tried a few recommendations that I saw online before writing. I checked in the Edit>Device Settings>Gcode tag & both boxes are empty.

But for now, here’s the background: I tried LaserGRBL first & things seemed to work well and normal, but I didn’t care for it much, so I downloaded & installed Lightburn. All that I did was add the device, then setup a couple of cuts & engravings on a piece of cardboard…I had to use the “Current Position” setting because it was doing the strange centering behavior when I would tell it to go to the Origin.

After receiving your last message, here’s what I’ve done: (I had it unplugged from USB & from power)

  • plugged the last into power & into USB (Lightburn closed)
  • powered on the laser (it was at 0,0 - bottom left-hand side before powering up)
  • opened Lightburn
    …when opening Lightburn, it did a Homing cycle by itself & here’s what I have in the console (it bumped into the limiting strips and gave this output):
    Waiting for connection…

ok

[ORIGIN: China]

[PRODUCER: ORTUR]

[AUTHOR: ORTUR]

[MODEL: Ortur Laser Master 2 Pro S2]

[OLF: 185]

[OLH: OLM_ESP_PRO_V1.2]

[OLM: GENERAL]

[DATE:22:44:33 - Oct 25 2021]

[VER:1.1f(ESP32).20210403:]

[OPT:VNMZHSLW,35,4096,3]

Target buffer size found

ok

Homing

ok

  • I hit the Home button & it just returned “ok” and clicked against the metal strips again
  • running the instructions you gave me before now:
    $I

[ORIGIN: China]

[PRODUCER: ORTUR]

[AUTHOR: ORTUR]

[MODEL: Ortur Laser Master 2 Pro S2]

[OLF: 185]

[OLH: OLM_ESP_PRO_V1.2]

[OLM: GENERAL]

[DATE:22:44:33 - Oct 25 2021]

[VER:1.1f(ESP32).20210403:]

[OPT:VNMZHSLW,35,4096,3]

Target buffer size found

ok

$$

$0=5.0

$1=100

$2=0

$3=6

$4=7

$5=7

$6=1

$10=0

$11=0.050

$12=0.002

$13=0

$14=6

$15=0

$16=1

$17=4

$18=0

$19=0

$20=1

$21=1

$22=43

$23=3

$24=600.000

$25=3000.000

$26=100

$27=3.000

$28=0.100

$29=0.0

$30=1000.

$31=0.

$32=1

$33=1000.000

$34=0.000

$35=0.000

$36=100.000

$37=0

$39=1

$40=1

$41=0

$42=1

$43=1

$44=3

$45=4

$46=0

$56=1.000

$57=1800.000

$58=395.000

$59=6000.000

$60=0

$61=0

$62=0

$63=3

$64=1

$65=0

$100=80.000

$101=80.000

$102=2124.000

$110=10200.000

$111=10200.000

$112=600.000

$120=2200.000

$121=1800.000

$122=200.000

$130=400.000

$131=400.000

$132=100.000

$259=0

$260=70

$261=70

$262=320

$263=30

$264=0

$265=50

$266=100

$267=0

$268=0

$269=0

ok

$#

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G59.1:0.000,0.000,0.000]

[G59.2:0.000,0.000,0.000]

[G59.3:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G59.6:201.000,146.000,0.000]

[G92:201.000,146.000,0.000]

[HOME:0.000,0.000,0.000:7]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

?

<Idle|WPos:-201.000,-146.000,0.000|A:S|H:1,7>

ok

Thank you, again, for all of the help. I will certainly hold off on making any changes or doing any cuts/engraving/etc until we figure things out. I’m in no hurry, so no problem at all, there. Whatever you need me to do, I’ll certainly do. (I’m powering off the laser & unplugging from USB & power now + closing Lightburn)

Thanks for the thorough explanation and rerunning the commands.

Interesting. There must have been an issue last time where not all the information was displayed. I see the offset that explains everything. I suspect this offset was set in LaserGRBL if you ever hit the globe icon.

The easiest fix to this will be to reset your settings to default. This is perfectly safe with your laser model.

Issue this command in Console:

$RST=*

This will remove your offset and also revert the $10 to default settings. The net effect of this is that the lower left after homing should now report as 0,0 if you use get position. This will allow you to use Absolute Coords which I recommend until you are very familiar with how your laser works.

After running the command I suggest you power cycle the laser and then retest using Absolute Coords. The workspace should mirror your actual laser bed and is the most intuitive coordinate system.

Additionally, I suggest you update your firmware to the latest version as there are a few things that they’ve fixed to address common problems.

You can find your firmware here. Make sure you very carefully identify your specific model as it can be a little confusing.

Ortur – Firmware Repository – Ortur

Thank you, again! It took a couple of different attempts & power cycles, but it is now mirroring the bed. (and you’re right - I definitely did hit the globe icon in Laser GRBL)

I really appreciate the help! I will now go to the link that you gave and update the firmware.

Have a great week!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.