Accessing camera crashes LightBurn - Ubuntu 22.04

I’ve seen this reported a couple of times, but none with a clear resolution.
I’m running Ubuntu 22.04 with Logitech C270 USB webcam. It works fine on the OS with Motion, but as soon as I select it or the laptop’s internal webcam LightBurn 1.6.00 crashes.
Other than trying an older version of Lightburn (which I don’t think is an option on Ubuntu 22.04?), are there any known resolutions for this issue?

Thank you.

Are you using the AppImage version? If so, there’s a known issue using the camera with that version. Try using the 7z version to see if the behavior is different in that case.

I’m using the .7z version. But I’ve tried with the appimage, too, and when selecting a camera with that one absolutely nothing happens - the app doesn’t crash, but no camera can actually be selected.

Are you running LightBurn from the command line? If so, is there any output from LightBurn immediately before crashing?

I’d been launching by double-clicking AppRun, but I just tried from command line. Results are below.

On launch this 1st section is in Terminal, and the app remains running:

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
Using the core prefs dir
QMetaObject::connectSlotsByName: No matching signal for on_actionSettings_triggered()
QMetaObject::connectSlotsByName: No matching signal for on_actionEdit_GameControllers_triggered()
"wlp2s0" "wlp2s0"
"tun0" "tun0"
"C270 HD WEBCAM" "/dev/video0"
"USB2.0 Camera: USB2.0 Camera" "/dev/video2" ```

**Then, when choosing a camera the below is added, then the app crashes**

``` "C270 HD WEBCAM" "/dev/video0"
"USB2.0 Camera: USB2.0 Camera" "/dev/video2"
res: 160  x  120
res: 176  x  144
res: 320  x  176
res: 320  x  240
res: 352  x  288
res: 432  x  240
res: 544  x  288
res: 640  x  360
res: 640  x  480
res: 752  x  416
res: 800  x  448
res: 864  x  480
res: 800  x  600
res: 960  x  544
res: 1024  x  576
res: 960  x  720
res: 1184  x  656
res: 1280  x  720
default: -1  x  -1
Setting res: 1280  x  720
Segmentation fault (core dumped)

Take a look through this post. Somewhat similar circumstances to you but using a different distro.

I don’t know anything about an intel-vaapi-driver - I’m using a Sony Vaio laptop, not a Dell as the other user reported. But I installed the gstreamer-plugins-bad package. The app isn’t crashing now, but there’s a new error in the terminal when selecting the C270 camera.

CameraBin error: "Device '/dev/video0' cannot capture in the specified format"

So I’ll be looking into running that down later tonight. Not sure if ‘format’ refers to mkv or 800x600 resolution, or something else, or where, yet, I might find those settings in LightBurn.

Thank you for your help!

I’ve had no luck finding any references to “the specified format,” or where that format is set.
On launch from the terminal the message still shows CameraBin error: "Device '/dev/video0' cannot capture in the specified format"
Now, whether I launch it by double-clicking the AppRun icon or from the terminal, the app no longer crashes, and the C270 camera is still selected, but its display is black, and the 3 buttons above it (update, trace, save) are disabled.
If I try switching to the laptop’s internal webcam, the app still crashes.
Maybe my Ubuntu 22.04 laptop and Logitech C270 webcams are simply not supported / not supported yet?

That’s an interesting bug you ran into.

What does “sudo dmesg” say after that camera issue happened?

Would you mind opening a ticket with support so I can follow up with you after the long weekend here?

I hadn’t run dmesg when the error occurred, but will try that the next time the issue occurs.

I’m exclusively running the AppImage version now. The .7z version now crashes immediately upon launch, but this is likely due to the fact that, after I’d had the .7z version running, I’d unplugged the webcam and apparently plugged it into a different port when I reconnected it. It now has a different /dev/[video#] assignment and the app doesn’t like that.

1 Like

@grumps that different /dev/video<#> issue can be resolved generally by rebooting the system. Yes, I know, Linux isn’t supposed to work that way, but it still has a number of cases where a fresh boot is needed: zombie processes, devices being unplugged while the port was open, etc.

I’m really curious what the console output of the .7z binary says if you can provide it?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.