Accuracy cut problem inner shapes


I’m new to Lightburn and Ruida, although I used for several years Lasercad + AWC608.

My current (recent) configuration :

CO2 Laser tube / around 70W / spot size around 0.2mm / 900mm x 600mm

Lightburn 0.9.18

Controller : Ruida RD6442S-B(EC) purchased by Cloudray Laser recently.

The problem :

I have 2 shapes, 1 part outline, and 1 opening inside this part, as attached.

When I cut the part,

If I do not use the kerf function : the outline is too short 0.2mm for both X and Y axis with regards to the drawn dimensions, which is to be expected, and the opening is spot on (accuracy around +0.02mm on repetition of the test), which is rather unexpected.

Said otherwise I measure 34.3mm for outline width and 69.6mm for outline height
But the opening is measured at 20mm for the width and 30.5mm for the height.

If I use the kerf function : the outline is spot on the drawn dimensions, and then the opening is too small of 0.2mm on X and Y axis …

Said otherwise I measure 34.5 for the outline width and 69.8 for the height which is correct
But the opening is then measured at 19.8mm for the width and 30.3 for the height

I tried to drop the cutting speed in case some interpolator would maybe cause the problem, from 25mm/s to 10mm/s , same problem.

Did anybody get this problem ? Am I missing a setting parameter ?

The only place I found something is in :

Edit >Settings >File Settings >Output Tolerance >Curve Tolerance (mm)

which I set to 0.005 (mm) ???

Thanks for your help


sample.lbrn (15.8 KB)

That is going to send a lot of extra data to your controller. 0.05mm is the default, and that is the maximum distance between the “true” curve of your shape and the lines emitted to the controller to approximate it.

With the kerf offset, your output looks like the dotted line surrounding the original design:

Because the inside is offset away from the shape (into the hole) while the outside is offset in the opposite direction.

There is no reason (or software setting) that I can think of that would make the inside dimensions correct and the outside incorrect, or vice versa. That is quite strange.

Hi Oz,

Yes I know about the increase of data but I wanted to try all possible ideas before asking, in order to avoid people loosing time.

Anyway your answer has a positive issue : you confirm that my database is correct, and this is important because, after I sent this message, it came to my mind that there was one test I didn’t made.

So I did quit Lightburn, and launch RDWorks 8

On the dxf import, and non compensated database (so no “offset” of the curves), I obtained something similar, I mean : the outer shape is 0.2mm too small as expected and the inner shape spot on , which is strange as it should be 0.2mm too big… so I started to put my design in cause but your confirmation it is clean is a relief. :face_with_raised_eyebrow: :face_with_raised_eyebrow: :sleepy: :sleepy: :sleepy:

I will try to find time to make more tests, it might be interesting to check wether this inaccuracy is a constant value or variable.

So, I think this might be a case for Ruida’s tech support I’m afraid (or Cloudray Laser whom I purchased the controller from)… I will try to contact them directly.

Thanks for your reply.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.