Activate License On Raspberry pi 3 with windows

Hi,
i have used Lightburn on my Alfawise C10 CNC Laser Engraving and it works great.
But it was keeping my laptop bussy for 4 to 6 hours.
now i tried to use a raspberry 3 with windows as a controller and it works fine with the Alfawise software but unfortunately i cant connect the Raspberry Pi to the internet.

So my problem is i cant activate the lightburn license.

can you please help me out?

Thank You,
Bogdan.

If you have a license, you would run it on the computer without the network connection, enter the license key, then click “Request Offline Activation”. It will ask you to save a file that contains the machine fingerprint as an offline request. You copy that to a USB drive and bring it to a machine with a network connection, email it to LightBurn, and they process it and return you a response file that you use to complete the activation.

Thank You,

will do so

Respectfully,
Bogdan.

Are you able to run the trial on the RPi? It’s not Intel based, so I would be surprised if this works.

I have not tried. i cant Connect my RPi to the internet so it will not start.
i have put my license nr in and it told me that the offline activation file was created but i am to stupid to find it :(.
All i can say so far is that LightBurn starts and asks for the license or start free trial, if i push the free trial it crushes and says faild to connect to server as any other cases.
Now i try to find the file it has generated to sent it per mail so that i get the activation key, if i get it because i tried to activate the license on the card using a laptop.

Dear Sir,
you can now be surprised … It works Lightburn runs on RPi 3 B+
I did what i should have done from the beginning… connect to internet via cable since i was not able to activate wifi connection.
I started the trial period ant it runs now.
In my stupidity i tried to activate the licence by running Lightburn from the memory on my wife’s laptop and i messed up … Now i get the message that my device limit is reached.
Looks like i have to buy another licence and i rely do not want to…
Is there a possibility to cancel the device i registered today and register my RPi?

respectfully,
Bogdan.

I have added a 3rd seat to your license, so you should be able to activate it now. I’m very curious what the performance is like, both for Windows and for LightBurn.

Thank You dear Sir,

you are too kind.

it works slow but it works and is cool … i am now trying to establish the connection between my scrappy laser and the RPi they behave like ladies do not want to talk to one to another …

But in the end i hope that i might convince them to form a team :slight_smile:

i will keep you up to date with my progress

respectfully,
Bogdan.

I’ve got 5x 4G Pi4’s arriving tomorrow. I’m happy to test. I was going to use SSD, rather than USB stick.

Hi,
as promised i give you feedback about day 3 of the trial.
i have updated all drivers for windows i have used tweakbit for that.
windows now runs well, lightburn starts decently fast and runs peaty well.
but my Alfawise C10 still does not connect . . . i get no error message just tried to copy the settings i have on my laptop. If i go to find my laser there id does not find it so i tried manually with no results.
on my laptop i am running the version for the 64 bit windows - lightburn version 0.9.04 on my RPi 3 b+ the 64 bit will not run (processor not compatible) so i installed the 32 bit version 0.9.07 as i installed it yesterday i got error message that some .dll missing so i downloaded it and copied it manually.

To be honest i have no idea what i can do to solve the connection issue i will try connecting it to other devices to see if it is a problem with the RPi pr with the laser.

For a chemist i got pretty far.

Please tell me how your tests will rum.

Thank You,
Bogdan.

If it’s running BenBox LightBurn won’t talk to it. If it’s running GRBL you should be ok.