Adjust S (laser power)

My laser have a marlin firmware but the laser power is adjusted 0 to 100, not 0 to 255.

Today I’m dividing the value with 2,55 but it’s crazy. The is a way to tell to lightburn that s value goes 0 to 100?

Yes in the device settings under the edit menu. Change the value from 255 or whatever it is set at to 100.

Don’t find the option

Not in marlin. Others have :frowning:

Sorry, I was using Grbl when I looked.

I was under the impression that the 0 to 255 range was constant. Which version of Marlin are you running that it’s 0 to 100? I can expose this for Marlin, but you won’t have access to that until the next release. Is there a way for you to change it easily in your version of Marlin?

No… I cannot change the firmware.

I love the lightburn, but I have to change the S value by hand.

Well, if the next version will have these setting… Wow!!!

Yes, it’s done already. It’ll be in the next release. You still haven’t said which version of Marlin you have that has this value from 0 to 100 instead of 0 to 255. I’m curious where it’s from, because the official Marlin docs have the 255 range:

It’s a marlin based firmware (from a local manufacturer here in Brazil). Tomorrow I will se more infos.

The machine have a arduino due.

Everything is running perfect, except S scale