Adjusting size of drawing


I hope the following makes sense to somebody and they can help me adjust the way of my error :slightly_smiling_face:
I have a round drawing, it is a svg file. When i make it smaller or larger using the percentage button in the top menu bar and the i start the laser it comes out as an oval shape…I am using the wrong button to adjust the size? should i be using the height/width button to adjust the size of the drawing?
But the thing is on my screen is still looks round but the laser turns it into an oval…Hope this makes sense to somebody…

Thnx for your help.

Is the little lock icon set to closed?


When it is closed (locked) the X and Y aspect ratio will be maintained when you resize, if the lock is open the X and Y can change independently (converting a circle into an oval)

If it comes out on the laser as an oval even without changing the size, then the problem is the laser itself, not resizing in LightBurn.

You could test this by creating a circle in LightBurn by using the circle tool, and holding Shift while you click / size it - that will force it to be a perfect circle. If you run that circle on your laser and it comes out as an oval, it could be any of these:

  • The Enable Rotary button could be on (see the picture below)
  • Your machine might need to have the step length of either the X or Y axis (or both) calibrated

You haven’t mentioned what kind of laser you have - that would help steer you toward a solution.



thank you for your answer. I have a jtech 2.8 attached to my shapeoko 3 xl. Will try your suggestion first.
Have a great day!