Adjusting Workspace Size

Hello Everyone;
I’m sorry if this has been asked before but I found stuff like it but not exactly like my issue.
I have LightBurn installed on my laptop but I am trying to make the size of the workspace match the size of my laser workspace but just can’t seem to get it. When I click on the device settings, I get a message saying, not device selected. I have not connected this to the laser as I have 2 other computers that I want to design stuff on and i can’t connect them to the laser either because of where they are located. Just want the space on my software to match the laser. I contacted a lot of forums and one person said it could be a flaw but I’m not sure.

I’m really new at this laser stuff so please bare with me on this one.

Thank you in advance

Hello!
This warning indicates that you don’t have a machine selected.

The workspace size is pulled from the Working Size of your machine’s bed, which is set up when you add your machine to LightBurn for the first time.

Hence to change the size of the workspace to the size of your machine’s bed, you must have the machine selected in the Laser Window:

If the size of the workspace is still wrong once you’ve selected your machine, then perhaps your machine wasn’t correctly set up, and these settings can be changed in the Device Settings window (found in the Edit menu). The Beginner Walkthrough is the best way to learn more about that.

Thank you very much for the help. Greatly appreciated.

1 Like

Sorry but I forgot to ask this one question earlier today. When adding a machine to Lightburn, is there a way I can add Genmitsu? I was looking for a spot to add a specific machine that isn’t listed in the devices.

I have a Genmitsu 3018 with a 5.5W laser on the Bench.

I assigned it a regular GRBL profile and was fortunate it was correct.

After the communication begins you can capture the welcome or wake-up message in the Console window in LightBurn and confirm which version of LightBurn you have on your controller. Knowing that it’s 1.1f or 1.1h (or any other version) is useful. The string of letters next to OPT: also lets us know which firmware options were selected when it was built.


For test purposes, please select GRBL (not GRBL-M3 or GRBL-LPC) and attempt to connect.

Once connected, even if you select some nonsense numbers (like a 10mm x 10mm workspace) you can ask LightBurn to read the default values from the controller and get going.

1 Like

Thank you very much John. You were and are a great help. Hopefully so.e day, I’ll get this stuff… learning new things comes hard to me since i had a massive heart attack that affected my memory but im not giving up…lol…

thanks again for the assistance…

2 Likes

No worries! None of us are born knowing how to laser cut. :wink:
Even the best of us knew nothing about it, once upon a time! And I learn new things every day.

You’re doing great, and we’re here to help, should you ever need any again! :blush:

1 Like

one last question for awhile. I was adding my machine like you mentioned but when I got it all done, I noticed that the lines (grid) were no longer on my workspace in LightBurn. Is there a simple way to turn it back on so I can see it? All that I’m seeing in a square that’s the size of my workspace?

Thanks again, you guys are great.

Make sure the ‘Grid Contrast’ in the ‘Settings’ drop down menu is not ‘off’

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.