Adjusting Workspace

I’m running an Xtool D1 Pro 20 watt. It seems that I can’t travel the full workspace (430mmx400mm from the .lbdev config file, xTool-D1ProV3.lbdev).

I get that this is probably because of the larger size of the laser module, so I was trying to adjust my workspace to compensate. Under Edit->Device Settings, I changed my working size to the max travel without hitting my limit switches (430mmx393mm). So far, so good. Looks like the workspace grid changed accordingly.

Then I tried to center a primitive on the workspace. It looks like it is still shifted to the center of the old workspace. So I exited Lightburn and re-opened. Now my shapes can center to the workspace; however, the snap-to-grid function stopped working. I double-checked the Settings and it was enabled. Closing Lightburn and re-launching seemed to fix the problem.

So my question is - are these two behaviors normal or are they some kind of undocumented feature (e.g. - bug)?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.