Advanced Automation Eagle (galvo laser)

Has anyone added the Eagle 30 watt to lightburn? Mine is not autodetected and not sure how to manually add it. It does use ezcad 2 and is connected via USB.

I have not read of this device but you may be successful following the setup video for Galvo lasers. Is this laser USB connected? What can you tell me about the laser source?

I followed the setup on the video and still could not get it going. It is connected with a USB.
Is there a way to get information you need from ezcad 2? I read raycus somewhere in ezcad amd can’t find where now.

A bit of good news. It works with macOS Monterey.
Still not been able to make it work with Windows10.

That’s great news. Since you’ve proven compatibility with LightBurn it’s probably a driver, setup or permissions problem in Win 10.

I imagine you’ve seen the setup video.

1 Like

I did see and followed it to do both installs. windows and mac.
I will have time tomorrow to keep trying to make it work.

This is what i have found so far.
I do not have universal serial bus devices option.
I can see the laser in the device manager window, but it is towards the top of all device.

Are you using Windows 7?

If so, or the driver install doesn’t seem to be working for you, use the “Zadig” method in the documentation.

i’m on Windows 10. can “zadig” method be done in 10 also?


The drivers seems to install. I think the usb ports are mapped different on my computer. just a thought.

Yes - The Zadig method works for any Windows system.

1 Like

Finally had time to work on this. It worked with the zadig method. thanks

1 Like

Using Zadig fixed my usb mapping and was able to get the machine recognized by LightBurn.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.