Affinity Designer 2 Export and LB import

OK, I’m having an oddity with Affinity Designer 2 (AFD2) SVG export to Lightburn (LB) import.

I have a file I created a while ago in AFD2, it exports SVGs just fine when setting the DPI to 96 on export. LB imports at the correct size.

I have a file I created today in AFD2, what appears to be the same export settings, it imports smaller in LB.

I made a copy of the old file, then expanded the document canvas and copied in the new design. I tried to export, and yet LB imports too small.

Lightburn is set to 96 DPI.
Affinity Design 2 SVG export is set to 96 DPI.
No JPEG compression. Export text as curves. Set View Box. Add line breaks.

Here is my tool chain:

  • Design in Fusion 360 (F360).
  • Export SVG from F360 with Shaper Utility plug in.
  • If I import that SVG in LB, the size/shape is correct.
  • I need to add some text to the design, so I import F360 SVG into AFD2.
  • I add text.
  • I then export using SVG and settings noted above.
  • The AFD2 exported SVG is sized smaller in LB.

Attached are

  • F360 export - imports correctly.
  • AFD2 export - imports incorrectly.

I’d love any guidance. The new design is slightly large in size, from ~1000 height to 1400 height.
Thank you.

Correct - Fusion Export
Incorrect - Afinity Export

I have tested your two files in CorelDraw 2018 and they come in as two different sizes as well. I also tried importing your F360 generated SVG into Affinity Designer 2 and re-exported with a couple of different settings and I too get a smaller design. However, if I export from Affinity as PDF then it keeps the correct size. Perhaps it’s a bug in Affinity or maybe it’s just something we’re missing but maybe using PDF is a solution for now.

Thank you Marcus - The PDF solution may work for me for now. Let me give it a try after a couple more meetings. I appreciate the response and I’ll confirm if this works.

1 Like

@Marcus_Wakefield Nearly there. I did one PDF export from AFD2 and then dropped it on LB and it looked great. It didn’t have text in it.

I just did another PDF, attached, and though I can see text in a PDF viewer, when I put it in LB, the logo shows up by the blue text does not.

Any thoughts on this?

Note, I changed the file extension to .txt so it would upload.
Sys3 L Base Master.txt (20.1 KB)

IIRC LB doesn’t import text in a PDF (I could very well be wrong on that though). I thought there was an option to convert text to curves in the PDF export dialogue in AFD2 but I couldn’t see it so I selected the offending text and performed a ‘Convert to Curves’. I then exported and that worked when I imported to LB.

I’ve noticed that the blue text on my system doesn’t look the same as the PDF you uploaded but I put that down to not having the same font on my system.

I really appreciate your help. Though it is frustrating to run into trouble like this, I’m thankful you could help me find another way to “skin the cat”.

I was able to convert the text to curves and then export as PDF. Not ideal, but it works.

No problem!

Obviously I don’t know anything about your setup but just out of interest: Is there a reason you’re going through Affinity to add the text? Is there some reason why you can’t add it in F360?

Fair question.

This product has several variations. I found it easier to manipulate layers in Affinity with changing sku/part number. It can probably be done in Fusion 360. I mean, I know how to do text. Just since there are different objects, thicknesses and variations, I can import the elements in Affinity and then turn on/off layers to make the combinations.

Fair enough reason. I wish they’d hurry up with implementing ‘configurations’ in Fusion! There is always the ‘Sheeter’ add-in but I’m not sure how well that works.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.