After homing Laser moves to -360 y (10mm away from its max y movement)

As the title suggests, After rehoming my laser engraver, it perfectly rehomes at 0,0 but then moves to -360 according to the move tabs “get position” button. Another keynote is that on lightburns display my test design will be on the top left but the laser will move to frame the part on the bottom left. This makes me think the Y value is flipped but is still being read correctly by light burn but not by the machine itself?

Info about the Laser Engraver -
Wainlux JL3
According to lightburn’s console, it is running VER:1.1f.20180715 .
The machine does have limit switches. Lightburn is set to absolute coords. Not quite sure what other info I can include?

I tried reading the setup document in the docs section but got a bit confused and didn’t want to mess with it too much. What should I do?

After testing the laser, I have also discovered the image was flipped on its x axis. Being mirrored when engraving compared to what it looks like on my screen

Can you finish a homing cycle and then run these commands in console:


Please also provide the following:

  1. To which corner does the machine home?
  2. Jog the laser to each corner of the machine after homing and use get position to indicate the coordinates for each corner
  3. Screenshot of Device Settings

The machine homes to the top right.
Bottom left Corner - x=0, y=-360
Bottom Right Corner - x=370, y=-360
Top Right Corner - x=370, y=0. Note in order to do this I had to put y=360 and then hit go on the move to position section.
Top Left Corner - x=0, y=0. Still have to have y=360 in order to have it go to what lightburn indicates as y=0.

Here are the screenshots of what pops up when I run the commands you mentioned.

laser setting2

  1. Run this in console:
G92 X0 Y0
  1. In Edit->Device Settings change Origin to bottom-left.

Power cycle laser and retest.


If you don’t mind me asking why were these changes necessary and what did you read in the code that made you come to this conclusion?

The coordinates that you indicated for the 4 corners validated that the expected origin position was lower left. You can tell because although the actual values are off, the numbers decrease as you move left and down.

The G92 is meant to reset the offset that you see in:


However, recent experience leads me to believe that this may not have addressed the issue without proper setup or by itself.

What’s the current state of your laser?

So it is printing in the correct location relative to where it is on my computer screen. The images are no longer printing mirrored. So it seemed to have fixed it. Although I still find it strange that it rehomes at the top left but then moves all the way down to the bottom left as its resting position. Not a big issue for me and I can live with it.

Also thank you for helping me with this issue. I went on vacation and I tried it as soon as I got back.

I thought you had said it homes to the top right.

You can change the position the head goes back to at the end of a job in Device Settings.

Damn I really did say top right. I meant top left sorry about that. I must have messed up when I was putting in the other information

Haha. Well, seems to have worked out in this case. It helped that you listed explicit coordinates for every corner.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.