After upgrading X axis stepper and external driver -> X axis shifts to left during aser proces

Hi Lightburn community,

I own a Chinese 600x900mm 100W CO2 laser and have a lot of problems since I started to engrave photos on granite and on tiles.
The laserhead jumped sometimes a few mm to the left or right.

My equipment works with Lightburn in combination with a Cohesian laser board and Smoothieware.
After changing various settings in Smoothieware and checking the hardware, such as belt, attachment of the pulley and mounting of the laser head, I decided to upgrade the X-stepper motor with a type with higher torc and current and an external driver. (driver setting: 1.5A and 1/16 microsteps)
After upgrading the problem was pretty much the same. :frowning:

But now I have an even stranger problem…
When I engrave characters, the x -position shifts ‘nicely’ to the left from the beginning to the end of the process.
The character A almost looks like a cursive character.
To show this issue, I made the following sequence; burnt a circle, fill & line character ‘A’ and burn a smaller circle in the middle of the first circle.

The shifted x-axis is only visible when using horizontal fill (0 degrees) and almost not when fill with 90 degrees; vertical fill.
I couldn’t solve this problem and don’t want to remove the stepper motor and replace the stepper motor again with the old one.

I hope someone can advise me or help me solve this problem…
I played a lot with the settings in Smoothieware, such as speed and acceleration, but without succes.

Thanks a lot for all your ideas and responses…

Regards,
Henk

This may be similar to a configuration error found in Ruida controllers:

In your case, flipping the polarity of the Step signal to the stepper motor driver may solve the problem.

This is most likely a loose setscrew somewhere between the X axis motor and the laser head, allowing a shaft to rotate from one position to another under the proper forces. When the shaft slaps into one position, everything will work perfectly until the forces slap it into the other position, whereupon everything will work perfectly with a slight offset.

Start at the X axis motor shaft and try to loosen each setscrew along the way. If a screw is working itself loose, it’ll be easy to loosen. When you find it, twist the shaft back and forth inside the pulley / coupling while tightening, so that the screw ends up snug in the middle of the shaft flat.

Bonus: If your shafts don’t have flats under the setscrews, that’s a problem right there!

I’m 100% sure that the above advise is not the case in my equipment.
The original stepper motor had a fixed non removeable pulley and the new stepper a shaft with flat side where I firmly mounted the pulley.
The laser head is also firmly fixed to the rail bearing and belt.
The above hardware problem would cause random jumps of the x-axis.
I now have a regular shift of the x-axis as shown in the picture with the 'A ’
Thanks a lot for your reply!

I read about the issue with the Ruida controllers, but could not find a way to reverse the polarity by software as done with the Ruida controllers. Or is this possible with Smoothieware firmware?
I guess that I am not the only one who connected a stepper driver to the Cohesion Laserboard.
The Cohesion laserboard has a seperate connector for an external driver, (with common anode and no ground pin).
I have already tried to reverse the polarity of the pull signal by reversing the pull- and pull+ wire, but this caused problems.
I saw the the input circuit is via an opto-coupler circuit. So reverse polarity with a common anode will not work.
I will dig deeper into this by checcking the schematic of the TB6600 driver to see if I can reverse the signal internally.
But I can’t believe that my hardware setup is so different from others.
I’ll post my findings on the forum.
Thanks!

I’m not familiar with Smoothieware, but a quick search reveals the pin configuration doc:

You can have a pin’s output inverted by adding a “!” after this pin’s number in the config line, example:
my_pin_name 19!

Do that for whatever output pin you configured for the X axis STEP signal and see if that improves the situation.

If it fixes the problem, you should probably do it for the Y axis as well, because they likely behave the same way.

I suspect this will actually reverse the direction rather than shift the output.

Hi Ed,

You are magnificent!
I added a ‘!’ after the pin number in the smoothieware config file as you described and the problem was solved :slight_smile:
I hope that this solution can help other people too!
Thanks a lot,
Henk

Took me a good long minute to understand how this could work and had me confused.

Missed that STEP signal was specified. Well done.

AFAICT, anything with programmable polarities will be wrong half the time, so flipping it ought to improve things.

I’ll yoink this into the Smoothieware category and put another notch in my lipstick case. :grin:

1 Like