After using rotary, engraving in Y axis direction is not correct size

I have a 100W CO2 laser with RUIDA controller and chuck style rotary. After using my rotary, I removed it and reconnected the Y axis cable. Now when I run a job, it is squished down in the Y axis direction. I made sure the Enable Rotary selector was Off. Is there another place where the rotary may be enabled? I’ve tried a couple of files that worked just fine before and both are too short in the Y direction now. The machine homes just like it always has. Lightburn shows the correct size of the image. What am I missing? Thanks. Jay

Did you power cycle the controller, so it is back to the flat work settings?

Rotary Setup - LightBurn Software Documentation

Note: If you are using a DSP controller (Ruida, etc), when you change the rotary setting you need to power-cycle the controller, as some of the internal logic isn’t adjusted for the rotary setting unless you do this. Change the setting, close the Rotary Setup window to write the change to the controller, then power off the control board and power it back on. You will likely need to press the Esc (or stop) button on the controller to prevent it from trying to home itself, as the Y axis will not home properly.

The best place to check is Tools > Rotary Setup, because that always reads it from the controller. If you have the rotary toggle on the main window, that one doesn’t always get it right, depending on when you connect to the laser.

I restarted both the laser and Lightburn from a cold start and it is cutting the correct size now. I had turned off the laser to reconnect the Y cable but I don’t think I restarted Lightburn. I simply turned off the Rotary Enabled switch. Thanks for your quick replies.

Jay