Air assist solenoid fires rapidly on RDC6445G

Hello, also the same controller and the same problem. I have upgraded the firmware to the one listed (.18) Wind fires on and off between shapes. Have I missed some further settings somewhere ?

Manual does say it will output “special signals” if not enabled, but as far as I can tell it is enabled in the vendor settings

To add i have tried a downgrade (RDLC-V15.01.15) and wind works exactly as expected. Can’t find any change logs to see what I’m missing by running older firmware.

I have to say it sounds like even with the firmware patch for the wind problem on 17, it doesn’t sound like it had been resolved completely with 18.

I don’t have any reason to update my firmware. Very happy I didn’t. I could contact my machine’s builder Unique CNC and see if they can provide me with a newer version than 18 (if one exists).

The version rollback working does seem to suggest it is firmware related. I’m relatively new to this so the following could be my misunderstanding of things, but a further observation as I’ve been playing with Lightburn Focus test today, I enabled Z axis control within Lightburn and this problem returned (but i don’t think it is a Lightburn problem)

@colbee, @kreamuhely, and @madsci;

Unique CNC provided me what they say is the latest firmware. Although this one is also marked 15.01.19 (like the one MWLaser had linked), the one MWLaser had on their site appears to actually be 15.01.18.

I haven’t used the update, nor do I want to risk the chance of introducing wind problems. But here is a link to the file provided to me by Unique CNC if you want to see if this is the true 19 update and perhaps resolves the wind issues completely:!AuF_9AuOlmzhiZ5d8R3EaYlK5d1J1g?e=johXot

I installed it (It’s still showing up as .18) and it’s not the same file as the last .19 version that showed up as .18, but it still isn’t working right. I thought it was better after the last update, but last night we ran some raster jobs and it was pulsing multiple times per line again. I just tried the same job again after installing this file and it’s doing the same.

That’s unfortunate. I guess the only way it will get resolved is to alert Ruida of the bug and hope they resolve it. Other than that, you may try to roll back to a former firmware. Is that an option?

I’m hesitant to roll back to a version earlier than the one that came with my machine. Right now it’s not a show stopper - I can override the solenoid if I need to, or wire it back in to the status output again and just not have software control.

Came to try the update but looks like you’ve tried it - shame no success . If it helps, I’ve continued to used the rolled back version with no obvious issues and correctly functioning air assist.

HI I had this exact problem just now when I performed an upgrade to firmware 15.01.19 and also lost my auto focus. I downgraded to 15.01.15 and now both work again. Like you say cant be too good for the solenoid.

Hope that helps Regards Alan.
ps the link to 15.01.15 is on MW lasers site

G’day guys,
The issue of the Air Solenoid clicking on and off while the laser is firing can be resolved by adjusting the setting BLOW TYPE setting using RD Works.

There are 2 modes for Auto Air Assist Solenoid Valve:
1 Blowing while LASER ON - this solenoid will click on and off each time the laser fires.
2 Blowing while PROCESSING - this will click solenoid on and off for each mode set in the layers if Blowing Yes or No etc but now each time the laser fires. This is the preferred mode.

I have not been able to find the option to change the Blow Mode in Lightburn.

I have a new video on my channel showing how to change this setting.

Cheers Matt
MW Laser


@Matt, thanks for the explanation and demonstration.

Had this been a new feature introduced in later firmware? I have not seen this setting through the HMI with my combination of the .10 controller firmware and 10.01.02 HMI.

Here is that config area in my machine as as you can see it isn’t there:

On the machine you demonstrated with in the video, is the setting seen anywhere on the HMI menu?

Ironically, the laser on mode is how lines have always cut on my 6445. That makes sense. While fill / engraving the wind solenoid has always been constant (processing blow). I have what seems to be a combination of the two (set differently for line vs scan).

Stranger is how I see this setting show on RDWorks counter to how my machine operates with perhaps the older .10 firmware of the controller:

Great thats helpful thanks Matt, you don’t happen to know how the auto focus works in the new FW.

Regards Alan

Ah, this seems to have done it! I had to download 3 different versions of RDWorks to find one that had that setting and would talk to my laser, but I think the parameter stuck.

If this could be added to LightBurn, that would be great!

I haven’t seen this one before. I’ll have to hook up my 6445 finally and look to see what else is in there.

No I have not seen this in the HMI, My Tech support at Ruida only advised this method of changing the Blow Mode. I have heard that later versions of RD Works do not have this option in the User Tab.

Also note: I have seen some reference in this post relating to updating firmware. Please note if you do upgrade Firmware to RDLC-V15.01.18 it may disable your Auto Focus for those who have it installed. To enable it again it seems like the HMI does not activate it when you select Focusing Yes, but you can re-enable Auto Focus in the User Tab of RD Works v8.01.47 as shown in image attached.

focusing function

Cheers Matt

Using RDLC-V15.01.18
and RD Works V8.01.47
Enable Auto Focus Here
focusing function
Cheers Matt

Thanks very much Matt.

Note, the air assist setting is NOT available in older versions of RDWorks. I did not have it in my .41, but when I downloaded the .48 from the Ruida web site, and then selected my 6445G controller, it appeared.

Bad news is that unlike other settings, IT DOES NOT SAVE !!! It reverts to the laser setting every time the software is powered up, and it does not appear to save with the file either.

I have .05 for an HMI, but not ‘upgrading’ to the .07 until someone can tell me what it does.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Heads up for anyone similar to myself who may have just recently obtained a version of RDWorks for the purpose of this controller setting: