Air assist solenoid fires rapidly on RDC6445G


I’ve just wired up a solenoid valve to my RDC6445G’s WIND output and enabled it in the control panel. It works, but the problem I’m running into is that it seems to be linked to the laser pen up/pen down state and not just the start and end of a layer.

That means it’s turning on and off very rapidly, which can’t be good for the solenoid. Documentation seems to be scarce on the air assist setup. Is this configurable somewhere? How do I get it to stop cycling so rapidly, short of making up an external control circuit?


You did use a relay with a diode and not wired it straight to the solenoid?

I used a relay with an external snubber diode. It’s not an electrical issue - if I set it to cut a big circle with air assist on, the solenoid clicks on once and off once. If I cut separate lines like text, for example, it clicks on every time the laser turns on. And if I enable it in engraving mode, it tries to turn on and off with each pass.

I have the 6445 with a solenoid directly wired to the controller without a diode and I do not have any problems. The only time the solenoid closes and reopens is when changing layers. Otherwise it is on throughout the entire layer (engrave or cut).

What’s the current draw / requirement of your solenoid? Is it possible it’s too high for direct solenoid connection?

Mine is 4.8 watts, so at 24v that’s only 200 mA. The wind output is rated to 500mA

DIGITEN 24V 1/4" Inlet Feed Water Solenoid Valve for RO Reverse Osmosis Pure System

Mine’s also rated at 4.8W - it’s specifically a MettleAir 3V210-08. I’ve got it wired as shown in the RDC6445G manual, connected to pins 6 (+24v) and 5 (Wind) on CN1. It says the pins are all rated at 500 mA, so that shouldn’t be an issue.

Do you have pause enabled? IIRC, each shape triggers the pause, which triggers air assist off for me.

Where would I find that? In LightBurn or the controller config? Doesn’t seem like something that would reasonably apply in raster mode, but I’ll check.

Nope, cut-through is off and it does it in ‘fill’ mode too.

Do you think you could send me an .rd file with air assist on that has a few separate shapes, so I can see if my controller behaves the same way with the same data?

Actually scratch that, I just tried it with one of the files that came pre-loaded on the machine and it does the same thing. You can hear it here:

@madsci, there is some confusion apparently (and I’ve had it too) about how that cut mode setting works now.

Checked or unchecked, the value of the delay will still be applicable. Therefore you can still pause the start while not having the laser fire. Make sure the value of the delay is 0.

Also, I recall another report of a potential problem with this and it affecting a fill layer…

Let me find that link and I’ll add it to this post… (please hold while we connect you to the next available)…

Yep… here it is. So basically for now, change the fill layer to line, set dwell time to 0, OK to set layer, then change layer back to fill. I think maybe all you need to do is to make sure dwell is off to correct this:

Pretty sure that’s not what’s happening here. Delay’s set to 0, and I tried enabling burn-through mode with 0 delays just to make sure it was taking the setting.

I don’t think it’s LB’s fault. This happens even with the saved Hello Kitty engraving program, which was probably NOT generated with LB.

For the moment I just switched the solenoid over from ‘Wind’ to ‘Status’. Now the air turns on whenever it’s running a job. That at least lets me button up the machine again, even if it doesn’t accomplish my original goal of getting air under per-layer control. It also serves to prove that it’s not a problem with the solenoid.

Maybe try… :nauseated_face: (hate to even say) RD Works and see if… you know I don’t even remember if it has the air assist toggle on a layer.

But if it does, it may help to determine if it possibly a controller issue.

I don’t have a 6445 connected, but it’s possible there’s a setting in that hardware to control whether the assist turns on per cut or per layer. It would be worth checking the vendor settings in the controller (through the on-screen menus) to see if that’s the case.

I’ve been doing my best to avoid installing RD Works at all, but maybe I’ll have to.

Worst case, I can throw a microcontroller in there (or maybe just a 555 timer, or even an RC circuit) and set it up to hold the solenoid on for maybe 3 seconds after the signal drops. Shouldn’t have to go to that extreme, though.

Yeah, that was my thought too, but I’ve been through every screen I can find, many times.

Not that that means a lot. Seemingly the only relevant option is “If blowing”, which is not exactly the most obvious label.

(Seriously, why can’t these vendors throw a few hundred bucks at a cheap but at least marginally-competent English translator?! I run a tiny company but I’ve at least got a user’s manual for one of my products written in Chinese by a native speaker.)

I have that same solenoid You’re using in my parts cabinet and I remember (I think) it having a minimal amount of air pressure for it to work properly. Too low, and it would not work right. I use a low pressure regulator (0 a 30 psi) to my laser.

I bought it for my new laser and when it didn’t work as well as the solenoid I had on my previous laser, I repurchased the same water fountain solenoid I had been using.

I’ll try to tinker with it tomorrow and see what I find.

Yeah, I realized the pilot air requirement late, but I just installed the valve on the high pressure side of the regulator to avoid that problem. It should always have about 90 psi going to the valve.

And with the solenoid connected to the Status output it’s stable. No pneumatic or electrical weirdness.

I cannot get my machine to replicate the issue. I have changed every setting I can find on the HMI, through LightBurn, and the only other suggestion I can offer right now is to format the UDisk Memory (yeah I know long shot) and maybe also take a reading on Wind (CN1 Pin 5) while the job is reading with a voltmeter. Slow down the fill speed dramatically if using a digital mutlimeter so you have time to see if the voltage out of the pin is pulsing.

What firmware version is your board?