ALARM:1Hard limit triggered. Machine position is likely lost due to sudden and immediate halt. Re-homing is highly recommended

Please help. My machine is running perfectly for years, even last night using Carbide Motion.This morning I switched to lightburn, I did this millions of times without issue.

It is homing fine. The only thing happened was when I ran in lightburn, a warning ‘out of bound’ this is no big deal, so I tell it to go ahead. It did what it suppose to do. I stop the job. I tell it to go to the Original job. It went home instead. AGAIN I did this many times without issues, until this morning. It went home and bounced at the home-position making horrible noise so I shutdown power.

I spent all day fixing it with lightburn, even uninstalling lightburn and re-install it. SAME thing—I shutdown lightburn. Launch Carbide create. test everything. everything is OK.----go back to light burn ---- same thing here is the massage from light burn below--------------------- ok ALARM:1Hard limit triggered. Machine position is likely lost due to sudden and immediate halt. Re-homing is highly recommended.[MSG:Reset to continue]Grbl 1.1f [’$’ for help][MSG:Check Limits][MSG:’$H’|’$X’ to unlock][MSG:Caution: Unlocked]ok-----------------

Please tell me what is going on ------------ this never happened before - a few times a crashed in the home position by mistake, but nothing like this. What do I have to do?----It did not complain about limit switches when it is in Carbide Motion.

the 2nd images shows after it failed to go to original position. now those homing button is disable turn off because the homing issue

Everything worked perfectly last night.

“Hard limit triggered” means exactly that - you hit one of the limit switches on the machine and it stopped the job. This isn’t a configuration issue so much as a “you told it to go out of bounds” issue.

Do you use a workspace offset macro? IE, do you have “Use Laser” and “Use CNC” macros, and if so, can you show their contents?

this is very strange to me. before I have lightburn, I crashed a lot of time in the home corner and so worries but nothing damage or bad. this time after that out of bounce I never recover the machine using lightburn. But when I use Carbide Motion, there is no issue with limits switches and homing working. I can not understand when I turn on lightburn and click Home. It home perfectly and pull of 5mm perfectly. I jog to the work piece, set it as Original. jog to the left , the right, back, forward at .5 inch. Then I click on Go to Original job, it went home and crashed make noise and gave the above Alarm error. here are the 2 Macro setting see attached images -

Where does the machine home for you? Which corner?

You’re using “Current Position” mode as the ‘Start From’ setting, with a center job origin. Is that intentional? It means you would have to jog the laser head to the center of the work piece before you press Start.

I uninstall lightburn from control panel in windows. shutdown the PC, re-start the PC and install lgihtburn new version 9.21 below is the setting in console when I do a $$ — I notice $20 $21 $13 are set to 1- is this correct?

$0=10 $1=255 $2=0 $3=6 $4=0 $5=0 $6=0 $10=255 $11=0.020 $12=0.010 $13=1 $20=1 $21=1 $22=1 $23=0 $24=100.000 $25=2000.000 $26=25 $27=3.000 $30=1000 $31=0 $32=1 $100=40.000 $101=40.000 $102=40.000 $110=5000.000 $111=5000.000 $112=5000.000 $120=400.000 $121=400.000 $122=400.000 $130=845.000 $131=850.000 $132=100.000 ok

I have no idea - those are stored in your controller and not managed by LightBurn.

That said, $13 should be 0, not 1 - That is telling the controller to report its position in inches, not mm. LightBurn wants mm.

Yes. that is what I want. It has been working for month until this morning because of the out of bonce warning, and I told it to go. many time before I got out of bounce warning, told it to go and no issues at all, never.

I see, maybe this is one of the setting I messing with. I am setting it to mm and see. will let you know

it is strange, if I change the setting for example $13=0 - in machine setting if will display disable - so is $20 and $21 — the older version of lightburn which I had yesterday, $13=0, $20=0, $21=0 - new lightburn 9.21 hang this to 1—

LightBurn does not change that setting for you (or any setting, unless you initiate it).

I remember. everything was fine last night. I stop lightburn, switch to Carbide Create, maybe carbide create made the change for those setting. I never change any setting at all because everything running perfect.
this morning, work on lightburn, get the usual warning ‘out of bounce’ tell it to burn, I stop it in the middle of the burn. I click on go to Original, it went home and crash and never work again. I went back to light burn to reset the parameters as days ago I record it on not pad. I am going to uninstall the new version, go back to the old version to see if it fix my issue. I will let you know

Problems resolved. Here is how I fix the issues. See attached images - I set the Macro parameter for the Laser and for the spindle - VOILA it is working now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.