ALARM 2/no movement on jog

I need assistance, please.

Im getting the same error message, Ive been through all the forum posts regarding this matter, I’ve already read and re-read the absolutions coord/current pos/origin link as well.

I can’t jog my machine, it stays in a "BUSY"state and then i get this:

Starting stream

ALARM:2

On or near line 2:

Stream completed in 0:00

[MSG:Reset to continue]

also when I try to show last position, its completely off from where my laser head is located.

I’ve tried various different GRBL settings and none seem to work.

Here’s the first couple of lines on the GCODE

; LightBurn 0.9.15
; GRBL device profile, current position
; Bounds: X0 Y0 to X609.6 Y304.8
G00 G17 G40 G20 G54
G91
M4
; Cut @ 80.0001 in/min, 100% power
M8
G0X1Y1.0447
; Layer C00 Pass 1 of 2
G1Y0.2693S1000F80
; Layer C00 Pass 2 of 2
G1Y-0.2693
G0X0.13Y0.1346
; Layer C00 Pass 1 of 2
G1X-0.26
; Layer C00 Pass 2 of 2
G1X0.26
G0X0.204Y1.1804
; Layer C00 Pass 1 of 2
G1X0.1271Y0.8433
G1X0.0187Y0.135
G1X0.0167Y0.1366

You’re in ‘Current position’ mode and you likely don’t realize what that means. Switch to ‘Absolute Coords’ and read here: https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html

Ive come across that link in almost all the answers to my question and Im sure I’ll be using Current Position. Let’s give Absolute Coordinates a chance I guess.

My machine has limit switches for when I use Easel for carving but I dont have it set up to do homing sequence or anything. Usually I just jog it to the bottom left corner of my work piece. With Lighburn Im following the same process and have been following everyones steps(even yours from the answers you give others)

ALARM:2 is a soft limit, meaning you asked the controller to move outside of its travel limits, so something you’re doing is trying to move it out of bounds. If you home the machine, then use Absolute Coords, and your file is entirely within the page bounds in LightBurn, it’ll be within the bounds of the machine as well. With Current Position and User Origin, it’s on you to make sure that the job start + size of the job fits within the bounds of the machine.

Where can I send you a video? Im positive my settings are right, Ive run other jobs before during my practice time with the trial(still got some days left before I use my license for the software) lines, cutting stencils out, raster filling and I had it all “nailed down” Or at least it so I thought until yesterday morning, then nothing worked right.

In desperate need of assistance. Got some jobs to run and am just stuck. All my settings seem to be right but it keeps doing it.

You can post a video on YouTube as Unlisted and just link it here, or send the link to support at lightburnsoftware.

Have you done the workspace offset setup that’s described here?
https://lightburnsoftware.github.io/NewDocs/CommonGrblSetups.html

The most common issues are the $10 setting being wrong ($10 should be 0), the offset for the machine origin not being set, or the machine not being homed.

I see. My $10=115 and when I was changing it back to 0 it would just flip back to 115. I reinstalled EVERYTHING and now its working properly, Slow, but proper. I guess that can happen when switching between EaslePro & Lightburn? Is that something tht happens?

Also my limit switches were dead. New ones are on the way and so is the board for them…i really gotta be more carefull when switching between apps