Alarm 2 Problem

First forum post here! I hope I did this right and if not my apologies.

Ive been trying to make a value chart with my laser with each grid square being a different power and speed. Being that I can only have up to 30 layers I have to complete the grid in different sections.

I started the next section adjusting the power and speed for each layer but when I start I get the console message; Alarm 2: on or near line 5. My understanding is that Alarm 2 means something is out of bounds that the laser cant reach BUT the laser has no problem framing the work so why would it give me that alarm when I try to start engraving it? I could move it potentially negating the alarm but I don’t wanna waste another piece of wood just to start all over again and if this problem happens again I would like to know why and how else I could solve it.
Does it have something to do with line 5? Maybe I changed a setting without knowing I did.

Any advice would be appreciated

1 Like

Framing doesn’t include overscan moves, so it’s possible that you have an engraving using overscan that’s too close to the sides of the machine. Could that be it?

Without more detail it’s going to be hard to suggest what might be wrong. Can you show an image of your LightBurn window before you try to run the job?

I do have overscan enabled so that could be it but yeah heres what the window looks like right now.

Try moving it in from the side a little more. If overscan is on, that could be it.

even with it moved all the way to the center im still getting that message in the console

Reconnect machine

In console, while not in a busy state can you type $# and tell us the output please?



like this?

Ok so no offset
Could you save it as a Gcode

Open in a notepad and post the first like 20 lines please?


; LightBurn 0.9.16
; GRBL device profile, absolute coords
; Bounds: X270.21 Y111.98 to X384.67 Y156.02
G00 G17 G40 G21 G54
; Scan @ 1200 mm/min, 50% power
; Layer C01

LightBurn 0.9.16
G00 G17 G40 G21 G54
<< M8 >>

If we uncomment the Gcode seems is that M8 command thats causing trouble
In your layers do you have air Assist on?
@LightBurn shouldnt this command simply be ignored by Grbl?

I do have air assist on even though my laser doesn’t have that function but I’m pretty sure its been on the time while doing past tests.

ALARM:2 is out of bounds. Line 5 is the 5th line with content, ignoring comments, so one of these is the bad line:


If counting from zero, it’d be the G0 Z60 line - Does the Ortur have 60mm of Z travel? I’m assuming not, so the user likely has the Z enabled, and either has a very large “material (mm)” value and is using absolute Z moves, or has a large Z offset in the cutting layer.

@daverage - You should enable ‘Relative Z moves only’ in the Device Settings, so the Z will stay where you start it unless told to move otherwise. That will likely help.

1 Like

Ortur does not have a Z at all
So that might be the problem having Z enabled?

That could do it, yes. :slight_smile:

Omg that was it thank you so much idk how or when I did that but its fixed now!

1 Like


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.