Alarm:2 with bed removed

I finally have an adjustable bed for my MonPort 40. The first time I try to send a file to the laser I get the following message.

Just in case you can’t see the image, the message says Alarm:2 is a GRBL error. Since removing the bed of the engraver so I can use a scissor lift for an adjustable bed. I have no idea where or what home position is what.

Please any help would be greatly appreciated. Thanks

Can you elaborate on this? Is your machine homing properly? I believe your laser should home top-left.

If you follow these 3 conditions you should never see this message:

  1. your machine is homing properly
  2. you use absolute coords as your start from mode
  3. you do not move your laser head by hand after homing

Can you ensure these conditions and retest?

I turn the machine on and it does its thing. I click the home button and looking at the front of the engraver. The laser head goes to the rear left. I put in a simple design and select all then hold shift and click frame square. I still get alarm:2. When I look at the screen of the bed, the home point is in the lower left side of the screen.

After going out remembering I needed to set absolute coordinates and taking note of the home position for the bed. I selected absolute coordinates and positioned the design respective to the home position. The machine took off and framed the design. It is currently engraving in a mirror format. I need to mirror the image to have it come out normal. I hope it can cut the 1/4” wood itself in one pass. I have the focal point set so it should work. Thanks for the help.

So I take it you didn’t have the laser working correctly before the bed modification?

To fix the mirroring go to Edit->Device Settings and change the Origin position to top-left dot.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.