Alarm 9 Homing Fail: Beginner user

I’m having an homing fail.
The laser moves in the direction of the homing location (Bottom Left) but always moves the same distance and then stops al of a sudden. I have checked al of the wiring on the limit switches and they do work if I place the laser close enough for it to home but if the laser is to far from the homing location it does not home.

Post the complete error that is displayed on the Lightburn ‘Console’

It will probably indicate it didn’t reach the limit switches in the correct distance. This is a configuration issue, going on the basis that the switches work.

You can try to put it near the ‘home’ location, a few mm and see if it works there…

You can also manually trigger the switches, each needs to be ‘activated’ twice.

Good luck


Thank you so much for your reply.
i have done that, and it does work if i put it close by but not when i put it further away.
We did also try to enlarge the frame the X and Y values in the configuration but it did not work… any other idea will be appreciated.

Can you post the actual error message. I’m making assumptions now…

Mine does this when I power it up without power to the motors…

Target buffer size found
Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.
Grbl 1.1f ['$' for help]
[MSG:'$H'|'$X' to unlock]
[MSG:Caution: Unlocked]

If it worked and you have increased the ‘work area’ size, the controller will probably need to have some of it’s information updated.

You can print out a ‘machine configuration’ via the console by typing the command $$

An easier way to modify the values are ‘Edit → Machine Settings’.

Check that the Max travel on both axes are correct. This is mine, it’s 300 x 180 make sure they are correct for your machine.


Anytime you ‘change/modify’ something like this, use the ‘Save’ option to write them to a file before you modify them so you have a ‘pristine factory’ settings to fall back on. I have a bunch of these for different reasons…

Good luck


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.