Alarm error when framing

Receiving the following errors after setting up my new xTool D1 Pro. Frustrating to say the least seeing that I believe I’m tech savvy yet not getting past this problem.
I’ve tried this, as well as other suggestions on other posts, removed and readded the device several times to no avail. Still getting the following error messages even after re-homing ($H).
err:limitCheck
ALARM:1
Hard limit triggered. Machine position is likely lost due to sudden and immediate halt. Re-homing is highly recommended.
[MSG:Pgm End]
MPos:0.000000,100.000000,0.000000,0.000000
M314 N2

This last time before creating this post, I was successful framing right after adding the new device. Once I ran the framing for the second time is when the alarm went off and produced the error message.

I’m thinking I may need to hard set the X & Y boundaries but not seeing any directions on that. I may be wrong too. Just frustrating and getting annoyed after 2 days of troubleshooting.

Looking for any help possible and grateful for the responses.

Thank you in advance!

I’ve discovered another issue thats related to this post. Whenever the laser travel goes to the left, from either the top or bottom position, the alarm 1 is triggered. Traveling to the right, up or down has no issues whatsoever, even when using the arrow icons from the Move option. This occurrence happens when only moving to the left.

This sounds like you have some buttons selected wrong. You appear to be sitting in the wrong graph quadrant.

= Select Absolute Coords in the Laser window.
= Make sure the correct Origin button in the Device Settings window is correct
O O
X O
= Make sure you have the correct workspace origin, next to the Rotate label, selected properly.
OOO
OOO
XOO
= When you Home the machine, Get Position in the Move window should be near 0,0 in X & Y.
= Enter $# in the Console window. The work offsets G54-G59 should be all zeroes.

If this info does not help, come back and we will ask more questions.

1 Like

The crimped wiring connectors do not offer strain relief to keep the wire from bending or breaking off right at the connector where the crimp is made.

Use the move button to jog up or down (Y-Axis) and wiggle the wiring by pulling it to the right slightly. If you can make the error appear, you’re likely to have a wire that’s broken inside the insulation.

You wouldn’t be the first.

1 Like

Thanks all. After reviewing all of the suggestions, I removed the cables that were inhibiting the axis’ from reaching their destination(s) and rewired them for ease of movement. This resolved the problem(s) I was having.
Thank you

2 Likes