Alfawise c30 2500mw: Laser on, No Engraving

Hi there! I’ve been trying to learn how to set up my engraver but I have been having issues getting it to actually engrave anything. I’m running on Windows64, the laser is 2.5W, and the firmware is GRBL1.1 . I’m pretty confident the laser beam itself is focused, and laser mode is on, but when I run a job it simply follows the path with the light on.

I’ve combed the forums here for similar problems and I have attempted the most common solutions I saw:
Focus laser
$30 = 1000
$31 = 1
switch from mm/sec to mm/min
The laser hasn’t been dropped or anything catastrophic either.

I’m certain there’s things I’m overlooking, so apologies for any lack of info. I’d really appreciate any help/guidance on this, thanks!





































$31=0 (minimum PWM value)
$32=1 (laser mode enabled)

What speed / power setting were you using to run your test?

done and done. Again forgive the ignorance but can I ask why is it that I have to utilize the $31 and $32? And not the $30 Or is there a link to a beginners guide to these commands.

Also here are the speed settings

Each number corresponds to a specific setting in your hardware. This page is the official config documentation for GRBL firmware:
It explains all the settings and what they do.

The $30 value you already have set properly, which is why I didn’t mention that one.

Cool, much appreciated! The previous settings I changed didn’t seem to fix it though

I still havent had much luck!

Can you be more specific?

What is it doing or not doing that you’re expecting? What settings are you using? If I go to an auto mechanic and say, “I’m trying to drive, but I’m not having much luck” that doesn’t tell him whether it doesn’t start, has no wheels, is out of gas, or I can’t reach the pedals. :slight_smile:

I expect the laser to engrave/cut along the path that I have in the job. Instead the light turns on but there doesn’t appear to be any power. when I run a job it simply follows the path with the light on. The only thing I have changed was what you suggested. Otherwise, the settings are the same from the screenshots above

Speed: 600 mm/min
Max Power: 100

I can’t see anything in your firmware settings or your cut settings that would be an issue. Is there a button on the laser to set it for low-light focusing? If so, on some machines that overrides all power output settings.

Did the machine come with its own software, and if so, have you tried that to see if the results are different?

Yea, it came with Laser grbl and is updated to the latest version and gave similar results. I haven’t checked since changing those settings though. I’ll do that and update.

In the meantime, these are just some characteristics of my specific laser. Not sure if it would help but still!
1.TTL output power : 2500mW

2.Output stability : ±5%

3.Beam Mode : Square spot

4.Focus spot size : less than 0.5mm

5.TTL trigger mode : Active high(>DC 2.0V)

6.Analog control input voltage : DC 0–5.0V

7.Preheating time : <1Minute

8.Ambient temp : 15℃–50℃

9.Working life : >10000 Hours

10.Lens material : Professional focused optical glass

11.Spot divergence angle : <2mrad

12.LD input voltage : 4.7V

13.LD input current : 4.6A

There is also a little red push button on the board that may be what you are talking about but there was no labeling on the manual for it.

The red button on the board itself is probably a reset. The laser light button is usually on the laser module, if there is one.

nope! No button on the laser itself. Im wondering if it is a hardware issue with the laser itself? On a different note, when I got the cutter it came with a flashdrive and installation files. The “installation instructions” consisted of navigating to the exe and installing. But there are a a bunch of other things here that Im not sure if I was suppose to install or why there even here.

Also seriously, thanks for continuing to offer any help and comments, I really appreciate it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.