Am I doing something wrong with Dithering?

Coke03

The burning isn’t quite right on this. The circle is virtually black and the coke itself that should be black isn’t. 10,000mm/min, 10% power, image mode is dither, line interval .1, 45° scan angle. 5.5 watt led laser.

The fact that the dark parts are all outlined is very strange. 10,000 mm/min is 166 mm/sec - will your machine go that fast? (if you have an 8-bit GRBL controller, it’s unlikely that it will)

Are you using GRBL or GRBL-M3? What are the firmware settings in your controller? (Type $$ in the console and press enter, post the output here)

The machine is advertised with a cutting speed of 10,000 mm/min. It is a Genmitsu LE5040 (https://www.sainsmart.com/collections/genmitsu-cnc/products/genmitsu-le5040-cnc-laser-engraver-machine).

I am using the GRBL-M3 setting as the GRBL did some odd things when cutting where it wouldn’t gut the laser off when doing movements between cuts. I had read that the M3 was a better setup and would eliminate that and it did.$.txt (355 Bytes)

You’re better off using the GRBL driver (M4 - variable power) and just enabling laser mode ($32=1).

That will fix the laser being on between shapes and will give much more consistent power output.

I have made those two changed and am updating to 9.11. I will do some testing to see how that works. Thank you for your help.

It would help if I changed the correct parameter. Now I need to dial in my power settings again to see what works best. So far so good. It is cutting faster and seems to be doing a better job now that I have the speed and power about where it needs to be for tan card stock.

Other than engraving an image, will this affect my power and speed settings for other things I have worked out such as fill, line, fill+line?

Probably not, but hard to say - the laser mode setting will affect power output if you are above the maximum speed set in firmware, otherwise it shouldn’t have an effect.

Something is making a big change. I am running some power testing projects and the results are very different. In a good way thought. This means I should go through all of the my feeds and speeds for this machine and update the setting.

If you had laser mode disabled, it would make the laser stop for every power change, because it would assume you have a spindle, and would be pausing for it to speed up / slow down. It would make a big difference in overall time, but if you were using constant power mode it shouldn’t affect the power output much.

I noticed in one of my tests that 9.11 is still leaving things out if they are right on the X and Y minimum. I selected the trace and chose the option to move it to the lower left and it didn’t seem to move and still didn’t want to cut. I grabbed the elements and moved them randomly away from the left and bottom and then it was fine but no longer zeroed. :frowning:

You can turn off the check in the 0.9.11 release:

Your desire to have things zero’d is odd to me, given that your machine doesn’t have limit switches. Set the software in ‘Current Position’ mode and you don’t have to move anything: https://github.com/LightBurnSoftware/Documentation/blob/master/CoordinatesOrigin.md#coordinates-and-job-origin

It is mainly for repeatability. When I have a fixture in place and set the machine up relative to that. I will try turning off the Discard out-of-bounds shapes if possible option to see how that works. Thank you again for all of your help. I may have to play with the “Current Position” option as well. :slight_smile: