Another Power Scale Question

I’m sorry to ask again about power scale, as I have read many of the previous posts, but there is one thing that has me confused.

I understand from reading that the output power = min + (max - min) * power scale.

The question is where is the minimum power defined? In the layer itself, or on the Ruida control panel? The reason I ask is I used this online generator:

If you look at a LB file generated here, every layer has minimum power set to 100% (as well as maximum, which I would expect to be 100%)

So, if the equation above is true, then each cut will be at 100% power? So, either this generator is wrong, and the minimum need be changed on each layer, OR the minimum is defined elsewhere instead, such as in the Ruida control panel?

Thank you.

That generator is apparently broken. It should be setting Min Power to something lower than Max. I’ve emailed him.

He has an ‘Advanced’ generator that does appear to work.

Thank you. So, that makes sense now why my test project cut out the pieces, while taking what I thought were the real values, didn’t even score through the back side. I was creating a jigsaw puzzle, on a 1/16 card stock, with photo and masking.

My test project was always cutting at 100%. Yikes! Not what I expected …

One observation. The LB preview panel has an option button to shade by power. Evidently it does not use the same function to calculate the output power, as when I test preview on the incorrectly generated project (the one where both max and min are 100%), it shades nicely in the preview panel.

FYI, when you do connect with that author, I just tried the Advanced generator, and it still sets minimum = maximum.


Never mind my previous comment. I didn’t see there was a checkbox there to cause the minimum power to be correctly set. My bad …

“Shade according to power” just shows the percentage from ‘Power Scale’. I could modify it to scale the real power value by the power scale amount, but then if you showed a grayscale image at 5% power, you would have very little visible shading on the screen. There’s not really a “works for all situations” way to do it.

Both of the generators have that ‘this is a DSP’ switch on them - so it’s not broken, you just have to remember to enable that setting, and it’s more obvious on the ‘Advanced’ version. On the basic on it’s under the power settings here:


Right, I didn’t see the checkbox for “uses min power”. However, the basic generator, when you check this box outputs 0.0 into the min power setting, not the minimum power from the entry field. The advanced generator, however, does use the minimum power from the entry field when the checkbox is checked. I realize this is not your code, but it seems you know the author and might be able to convey that to him?

As for shading, I realize there’s no perfect solution. I would suggest, however, that given the problem I had with my generated project, i.e. min == max, that when showing the shaded preview, it was totally wrong. My test project burned at 100% in every square due to the fact that min == max, and I didn’t know or catch that issue.

Regardless, I now know what happened, and it won’t catch me again. Thank you for confirming what needed to be done.

I should have a Min == Max warning somewhere if you have data that uses power scale. That would be worth adding, at the very least.

Agreed, that would be helpful in this specific case. Given the several support threads that I ultimately found on this, it’s not an isolated incident.

To close this thread out, I just wanted to confirm how to use the information obtained from a power scale test job. As a theoretical

Min: 20%
Max: 80%
Increment: 10%

Assume I get cleanest cut in the 40% column

To now cut my full project I should set my output power to:

min + (max - min) * scale
20% + (80%-20%) * 40%
= 20% + (60%) * 40%
= 20% + 24%
= 44%

So, I should set my max power in my real project to 44%. I would also assume that I should set minimum to 44%, or I guess there are times that I may way it lower, so that areas of slow speed don’t overcut?


So, I just located this final response in a similar thread, which had a great table, which answers my question. It looks like my calculations above should be correct.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.