Another "There was a problem sending data to the laser, the machine may be busy or paused", but different


my name is Christian and I just finished my self-made 60W CO2 Laser with a Ruida RD6445S control unit.
All functions work very well at the Ruida (jog, pulse, speeds, etc.) and finally I managed to align all settings to my satisfaction.
The connection from my Windows 10 PC to the laser machine is done via Ethernet, the process was straight forward, very well described by the Lightburn community and worked very well at first glance since I could jog X, Y, Z and also updated all (vendor) settings from the PC very conveniently; so I assumed that the ethernet connection was ok.

Unfortunately I encountered the well known error message “There was a problem sending data to the laser, the machine may be busy or paused”, as soon as I

  • hit the START button in Lightburn or
  • try to send cut / engrave data to the machine with the Lightburn SEND button

I already tried all the trouble shooting described in this and other forums with no success at all:

  • Changed from PC-Wifi to an ethernet cable
  • Deleted and re-established the machine in lightburn
  • Right-clicked on the DEVICE button in Lightburn to reset the connection
  • Hit ESC, STOP and PAUSE on the Ruida each before, while and after sending the data to lightburn
  • Deleted all memory on the Ruida controlle (what was redundant since no actual cut data was on the machine anyway)

What really confuses me is that the connection is generally working; ok, I encounter a small delay of approx. 0.5 seconds when I jog the laser head, but I can control all movements from Lightburn as intended. As already stated above also all (vendor) settings adjustments have been performed in Lightburn, saved and that worked perfectly! Only the communication of actual cut/engrave data makes problems.

I noticed that Lightburn needs approx. 5 seconds until the error message appears, maybe there is a interdependency with the default timeout setting of 5000 ms?
Maybe Lightburn needs additional access to any UDP ports or similar to send the data properly (see also additional info below)?

Switching to an USB cable is not really an option for me since the laser is about 5 meters away from my PC and it seems that the connection is working in general (jog, setting updates)

I’m using

  • Lightburn 1.4
  • Windows 10 Professional
  • 10 m CAT 7 ethernet cable to laser machine
  • 15 m CAT 7 ethernet cable to PC
  • RUIDA RD6445S control unit (Firmware RDC-V35.01.03. I plan to update the firmware as soon as the laser is running properly)

I’ve disabled my firewall completely, no success
Laser responds as intended with RDWorks V8.01.54

I hope you have further ideas what the problem could be!

Thank you very much in advance for your support!

No suggestions?

I don’t think this is the case. LightBurn should use the same mechanism as RDWorks in transporting the job.

When you did this, were you sending like for like jobs?

Try one thing. Take a known failing job in LightBurn, then push “Save RD file” in Laser window, then save to a file. Run that file from RDWorks. Does the job completely successfully?

Alternatively, is running a LightBurn Bridge an option? I don’t see why your network setup wouldn’t work but if for some reason you’re getting packet loss or something similar than the Bridge may be useful.

However, this would only be useful if the RD file test works.

I finally managed to get Lightburn running.

Unfortunately none of your tipps worked, so I completely removed it from my PC, made a deep cleanup (registry etc.) and re-installed it.
Now it works as intended, no idea, what the problem was.

Did you attempt the RD file test? If so, what were the results?

In any case, glad it’s working now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.