Any thought on this, is this a software problem or a hardware problem?

I purchased a ORTUR Laser Master 2 ProS2-LF Laser Engraver on Amazon that was delivered on March 8th, 2022. I tried to use it, using Lightburn on a ASUS VivoBook Laptop using Windows 10.

My problem is that it keeps trying to burn off of my piece of work. In Lightburn, I enter a position of X= 200, Y = 200 and the laser head moves to the upper right corner of the frame. When I click “Get Position” Lightburn gives me the coordinates as X = 291.80, Y = 332.80.

Any idea as to how to correct this?

follow this video to setup correctly your ortur with LB

Had done that already, but did it again, still goes to 291.80, 332.80 instead of 200.0, 200.0.

we have to wait for @OrturTech

(answered via ticket but )
Seems you ahve an offset on your machine, x91.8 y133.28
So when you do X200 Y200 it ADDS those more offsets

Try this for me, in the console window
Type where it says
“type command here”
press enter
MAchine will respond with
MSG: Restoring defaults

Once done, reach for motherboard and tap Reset
Power on again. should be cleared

However to avoid this i recomend upgrading your firmware
Download, unzip and follow pdf instructions here

1 Like

Thank you, Gil, that solved the problem. However, when I tried to update the firmware, I could not open the motherboard for the update. Even using a timer, the combination of holding the power button for 5 seconds then while keeping the power button down, pressing the reset button for 1 second did not work.

I attempted to upgrade the firmware by following the PDF instructions, but to no avail. The “button-push” combination does not put this machine into “firmware update” mode.

Try this other sequence instead

Press and hold reset → While holding PRess and hold power, Then release reset

1 Like

Thank you very much, that got it and I’ve updated the firmware.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.