Apple computer with Morn Laser, Ruida. Laser not recognized

Can’t get Lightburn to recognize my laser. I keep trying to manually add it because ‘auto’ crashes my computer. Running OS X Mohave. Tried plugging brand new usb into port on outside and inside of laser. I’m pretty sure it’s Ruida right? Can’t figure out which.
Can I get some advice? Thanks

That certainly does look like a Ruida, though I can’t say I’ve seen one of those before. Auto is crashing because we removed a bunch of port filtering that was preventing some devices from being found, and now we’re back to tripping up on some that are found now that shouldn’t be - Bluetooth headphones, usually.

Do a full reboot of your computer (not just a sleep / wake) and try adding the controller manually. There are known issues with FTDI devices on MacOS, but there are a few ways to fix it - the simplest is removing the FTDI driver from the computer and letting the built-in MacOS driver deal with it.

If that doesn’t help, there’s a step we can try to see if your device uses a different scramble key than we’ve seen before and get it added.

Is this the file you’re referring to? it’s in Library/extensions.
My friend that’s helping thinks it’s not but worth asking.

I haven’t done this myself, but that looks like it, yes.

ok, we tried removing the file, and rebuilding the cache using kext wizard. I tried to manually add the controller several times in Lightburn, and lots of computer reboots. The manual talks about RDcam install, so Ruida verified. I have 4 usb ports and Ive tried to add manually after plugging into each port. I really appreciate your help, I’m looking forward to using Lightburn and my laser!

It’s possible that controller uses a different scramble key than any I support at the moment. If you have a Windows box and can run the stock software we’d likely be able to get it supported. Is that something you can do?

It’s a Ruida. I have a MornTech 6090 with that same controller. It’s old, real old. I believe it is the RDLC320 (not A, before they put them in the pretty white enclosures). It can only use up to RDCam (Predecessor to RDWorks) version 6.0, made for Windows XP. It doesn’t say anything in my manual about being Mac compatible.

You’re going to have to use a Windows machine and find a copy of RDCam 6.0, I think you can still DL it from Ruida. I can run 6.0 on a Windows 10 machine, but I don’t remember if I was doing it in XP compatibility mode or not. I have RDWorks 8.0 installed on the same machine for my other laser and they play together just fine, but just in case, if you have a version higher than 6.0 and you don’t need it, I would uninstall it and its drivers before trying to talk to the machine. The driver for the 320 is different than the one for the 6442x.

Thank you very much for the information. I went and bought a pc with windows 10, I’ve tried multiple versions of rdworks 5 and 6. A nice person at Morn is trying to help me find a solution, right now she’s waiting to see if they have the driver still. Are you running the laser on rdcam6 with windows 10? You don’t use lightburn with it do you?

I was, yes, but I was not using LightBurn with it. Since I converted my better machine to a Ruida 6442, I don’t use the Morn much anymore. I have the CD that came with the Morn with RDCam V6.0.08, the manual, the driver, and strangely, a video named mt3050d instruction.wmv. I also have some other versions of RDCam and drivers - I’m not sure which I’m running on my laptop. Since my machine is a 6090, I don’t know whether it would work for you, but I could look on my laptop this weekend and figure out a way to get you the files if Morn doesn’t have a better solution for you. I would also suggest heading over to and seeking help there. One thing you need to do though is get to the back of your machine and take a picture of the control board to confirm which one it is, and try to get a better picture of the underside of your input panel as well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.