Art library stencil "font" issue

I have this art library that is a stencil “font”. When I drag one of the images into the work area it immediately changes it to whatever the currently selected font is in LightBurn.

I assumed that this was a library made up of svg files but can’t be certain.
Is this something Lightburn is doing?
Can you look inside this file and come up with the reason?
FWIW, I just did a test. I created a test library, placed a text character on the workspace, impoerted this into the library. I cannot reproduce what happens with the attached library.

stencil-military.lbart (432.0 KB)

I’ve asked the rest of the team for some help with this one as I’m not so savvy with fonts and their file structures.

1 Like

Just tried it, it’s very, strange, interesting to see what the cause of it is.

1 Like

It looks like they’ve been saved in the library as characters rather than graphics. I’ve tried the library and it works for me. The characters come in as font ‘STENCIL’ and looking at the font properties it’s a Microsoft font. Quite why someone would go to the bother of creating an art library of characters doesn’t make much sense to me but maybe I’m missing something!

I’m not sure whether this font is freely available but you can no doubt find many similar (and probably identical) fonts one of the free font sites.

Correct, the library is constructed using font data. These characters have not been converted to paths / shapes, so one is required to have the font installed and selected for this library to produce as expected.


A key indicator that these library entries are fonts and not just vector paths, is that when you drag one onto the workspace, you will see the ‘Blue-Dot’ text bending visual indicator, which is only shown if you select a LightBurn text primitive.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.