AtomStack A10 Alignment Issue

Hey there,

I wanted to check, the alignment performance of AtomStack A10 Pro and when I run the same project after the first run, it does some shifting as you can see picture (way more than the tolerance of the machine tho)

However, after the 3rd round, the machine is not shifting anymore.

I do have some example pictures and attached them for your reference.

For a workaround, I run laser with the 0 laser power and run the course at least three times over the workpiece. Once I am convinced that the machine is not gonna do shifting, I increase the power of the laser and do engraving/cutting.

Appreciate any help from your side in order to fix this issue

The issue is most likely mechanical. Check for proper belt tension and that the pinions are properly secured to the stepper shaft with grub screws.

It’s also possible that you are speeds are too high and your motors are skipping. What’s the current speed setting?

Hello there,
As per your suggestion, I checked belt tensions for Y & X axis. I think I have some improvement for Y axis but my problem in X axis still there… Already did the same belt tension adjustment for X axis ( along with controlling all sort of screws) and still I do receive same results :frowning:

attached some more test pics below
speed was 250, and laser power was %15

As far as I understood, problem is related with the X axis. However, after the 3rd round of shifting towards right,4th run is following the 3rd round’s same coordinates.

Appreciate any suggestions

For clarity, can you confirm that you also took the belts off and inspected the pinion on the stepper shaft? It looks like your x-axis pinion is not properly secured and giving significant backlash. You won’t be able to properly check for this with the belts installed.

There are likely 2 grub screws at different parts of the pinion. The primary one needs to be secured to the flat portion of the stepper shaft. The other one should be similar secured. If you noticed that these are getting loose then you may want to use some thread locker to prevent them backing out.

Thanks breainlb,
Yes I do confirm that I took the belts off and controlled/loosened and assembled the pinion on the stepper shaft (already twice)

However still same result :frowning:

I really dont know what to do anymore…
Maybe it is related with the Xaxis step motor instead of pinions and shafts connection?
any ideas?

If the machine is off are you able to freely move the laser head to the entire range of the machine? It should glide smoothly with no binding at any point. Do this slowly as this actually induces a current from the stepper motors that can feedback into the other electronics.

When you did this did you find that any of the pinions were loose? Can you confirm that the pinions are now securely attached and has no play on the shaft (not just that the grub screws are tight)? It’s possible that there are 2 grub screws stacked on top of one another. In that case you’ll need to remove the top screw in order to properly tighten the bottom screw.

It’s possible that the belt tension is still incorrect. There should be no slack in the belts. They should be taught but not stretched. Temporarily overtighten them to see if you can remove the skipping. Make sure that there’s nothing keeping the belts from being aligned properly. Is there something out of position that’s putting the belt out of alignment?

Check the belts for any damage to the teeth or any debris that could be interfering with smooth motion.

What are the units for this number? Does dramatically slowing the lower change the outcome?

just a question, the carriage move on wheels? if there is some eccentric nut check also that :wink:

im a real newbie as im having the same issue 4th or 5th try it might work ill have to do some research as I have no idea whatsoever what screws mentioned in this post

I have exactly the same problem as described, the recordings do not match and they keep scrolling to the right. From what I see, I am concerned that it may be a manufacturing defect. Gracias, y perdonad mi inglés de traductor :sweat_smile:

my machine is Atomstack A 10 PRO, and I just bought it and installed it following the manufacturer’s instructions. I also have another problem: My MacOs computer cannot communicate with the recorder, although I have installed LightBurn and CH34xVCPDriver drivers
that brings the machine from the factory

Hello, I just installed the Atomstack A10 PRO burner, I use Mac and I have installed the program that came with the machine “LightBurn 1.2.04” (I have also installed “CH34x_Install_V1.4.pkg”, an attachment that comes with the LightBurn program ) but when I try to engrave a job I get this message: “There was a problem sending data to the laser, the machine may be busy or paused.” Thank you very much

Have you fixed your atomstack 10 ?
Iv got the same problem with alignment :frowning:

I have the same issue with my rebranded A10. The issue only occurs on the X-axis between successive job runs. The only thought I’ve had so far is maybe the laser module is twisting sideways as the carriage stops quickly at the limit switches. I am yet to test this though.

Hey there,

When I could not overcome the problem using the recommendations of the users on this topic, the manufacturer’s installation instructions and at least ten different methods I found on the web, I found the best solution to sell the machine :grinning:

I have bought a 130w chinese co2 laser and pretty happy with it so far.

Note: My final thought is atomstack has some basic manufacturing errors tht cause this problem.

All the best