Atomstack S10 Pro locks up when connecting to LB


I have been using LB for about a year and a half with my Atomstack S10 Pro (10W diode laser, GRBL controller). It worked fine until about 6 months ago. Then the touch screen started turning white on the controller when I connected with LB. Some times I would play the game of pull the USB cable, plug it in, power cycle the laser, stand on one foot, then the other – and BINGO it would connect and I could run it for hours or days. Then I would power down.

I am running W10 22h2 and the very latest LB and I have upgraded the firmware 2x on the controller because of this issue
At this point I can’t use LB at all – if I select Com6 to connect, the controller locks up and I have no access. I can change LB back to Choose port and the controller will restart and be fine

I can connect with lasergrbl and operate the unit fine with that, but it is no comparison to LB – I really want the real deal back so any help would be appreciated!!


Can you provide the following:

  1. full screenshot of LaserGRBL immediately after connecting to the laser
  2. screenshot of Edit->Device Settings in LightBurn

What does fine mean in this context? Where does this leave you?

Fine means the controller has the blue carve and settings button and I can go into an NC file and do a cute, but I don’t do that EVER so it leaves me with a $1000 paper weight – I could use lasergrbl but that is one step up from a paper weight compared to LB – So I am dead in the water

Got you. Are you able to provide the two screenshots listed above?

LOL, no – after 2 hours of everything under the sun it connected and is ready to work in LB
What did I do…
I had the MKS laser tool software open and connected to the ESP32 controller on Com6, I flashed the firmware again, reset the size to 410x850 and reset the WIFI settings and was connected to it with MKS tool when LB opened and tried to connect – upon closing MKs tool (Releasing Com6) LB connected

I have deleted and readded everything so now I need to do a test cut and see if anything works right then reboot

So are you now able to reliably connect with LightBurn? As in problem solved?

Problem not solved, but I have what looks like a reliable work around. I rebooted and had the same white screen on the controller when LB opened and connected on Com6
I disconnected LB, opened the MKS tool, went to WIFI settings and connected
I told LB to connect and got a port busy error
I disconnected MKS tool and LB auto connected and is fine/stable
see order of screen shots below


Try enabling “DTR Signal” in Edit->Device Settings and see if that makes connecting more reliable.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.