Atomstack X20 Pro only very faint laser output, no power. First Time Use


I have an Atomstack X20 Pro just setup new out of the box, in the official AtomStack case.
All seems to be working and is connected to the PC fine, Lightburn installed and all talking to the machine.

I am testing by drawing a couple of simple lines and some text, setting it to various power between 20% &100%. Cutting speed set right down to a crawl.

The machine is only producing a small blue dot (the same dot that LaserGRBL software turned on to show position) but nothing else.

Also trying to burn / cut the simple test patterns provided with the machine, machine in stand alone mode produces same result so im pretty sure its the machine and not any Lightburn settings.

I have checked the settings for S Max when compares to $30 and both are on 1,000.

I have checked all connections on the device (especially the 4 way to the laser head) and all seem fine.

Any ideas?

Can you make a simple design of a square with cut settings of 100% power and 100 mm/minute speed?

Then push “Save Gcode” in Laser window and save the file with a .txt extension. Then upload here please.

square.txt (16.6 KB)
i think that should be it, thanks for the reply

One thing I’m noticing is that you’re using the wrong device profile. You’re using GRBL-M3 but you should be using just standard “GRBL”. This shouldn’t cause the issue that you’re seeing but let’s remove that as a variable.

  1. Push Devices button in Laser window. Click on your laser, then edit. Change to “GRBL” profile, then Next until done.
  2. Test laser
  3. If that doesn’t work, can you resave the Gcode file and reupload?

Hi, setting changed. Same result when testing again.
(Very fine laser dot where would expect the cut to be but all moves along the path to cut as expected)
File attached
square 2.txt (16.5 KB)

The gcode looks find and it’s definitely specifying max power based on S Value Max of 1000.

Are you certain $30=1000?

You didn’t indicate whether or not this worked in LaserGRBL. Based on what I’m seeing you should have the same problem there.

Also, have you made any configuration changes to the machine?


New to this but as far as im aware $30 should be 1000. I queried it from the console by sending ‘$$’ and it brought back ‘$30=1000.000’ (with all the other settings).

No it did not work in LaserGRBL, same results.

No i don’t even know how i would make a config change, i will look at resetting the machine controller to default.

Thanks for your help this far, i think i may have a faulty laser unit.

I don’t think there’s value in doing this if $30 is indeed set to 1000.

I think this is likely. Or, possibly you have a power supply issue.

Do you have a meter that you can use to test proper voltages from the power supply and going to the laser module?

Faulty power supply!
Running the controller fine so i’d disregarded it.
Swapped with the one from the air assist and cutting away now.

Thanks for all your help, im sure i’ll be back with more questions soon!

Thanks again.