Atomstack x30 Pro No Sd Card Problem

I want to use my device offline. I bought a samsung 64 Evo Plus sd card for this, but when I insert the card, I get the No Sd Card warning. What would be the reason. Sd card in exfat format.

Most common issues with card incompatibility will be related to:

  1. SD Card type. Not all cards are the same even if they look similar. SDXC is different from SDHC and SD. MMC is also different than SD. TF Card is also different than SD. Having said that, there’s a lot of overlap and effort to make these compatible but some readers are more picky than others.
  2. Filesystem format. Not all readers can use exfat. And not all formats of exfat are the same. I suggest using the SD Memory Card Formatter from the SD association:
    SD Memory Card Formatter for Windows/Mac | SD Association (

If you can check for specific compatibility from the X30 Pro that would be easier or else you can simply try various combinations of card/format.

Thank you for your help. This is how I solved the problem. No 64GB sd card support. I split my card into 20gb. Then I formatted fat32. This way the problem was solved.

Thanks for this solution! I had the same issue, but with the manufacturer’s supplied card. I’m not sure what caused the initial problem, but reformatting to FAT32 worked.