AtomStack X7 Pro Not Working

Bought X7 Pro towards end of November. Still in the box until a few days ago. Assembled and wired correctly. Standalone LCD screen appears to be on but can only see gray screen. Red light on laser board is on but no light at business end of laser. Inserting micro sd does nothing and Lightburn Software does not “see” the laser. Has anyone had this problem?

My X7 runs well thru display and on LaserGRBL software but I have the same problem with LightBurn. Thy system just cant find the laser.

Try configuring the laser manually. If required, use the same COM port as what as laserGRBL was using.

I have the same problem with the Atomstack A10 Pro model which should be identical in construction. Again, Lightburn does not find the laser. I chose this model because I was told it would work with Lightburn as well as my other Sculpfun s6.

How can the problem be fixed? Use Lightburn with Mac OSX Catalina.

Need help urgently!!!

Did y’all ever figure this out? I am also stuck at a gray screen, also from the very first time I turned it on. I checked and reseated all the connectors, changed out the HDMI just in case.

I’ve tried putting in an SD card, and I’ve tried booting with the USB connected to my Macbook Air. The outcome is the same in all cases: from the instant I turn on the power, the fan comes on and the screen wakes with a uniform gray, but then nothing.

Hahahaha. I figured it out as I was filming a video for support. For future readers:

It’s the Emergency Shutoff button. The big red one. During shipping or assembly, if the button got pushed down it will stay there until you twist it to pop back up again.

While that button is down, the screen will only show a uniform gray. Twist the button, it will pop up, and the screen will go back to showing what you expect.


Yet another noob that can’t connect his X7 to light burn works fine with laserGRBL… seems weird that lightburn does not include a profile us noobs can manually select and import? No one have one? Just so odd that LaserGRBL can pick it right up but, what I would consider nicer software (lightburn), can not…

I suggest you just create the device manually. I think there are literally just 3 choices you’ll need to make:

  1. GRBL device type
  2. Bottom-left origin
  3. 410x400 engraving area
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.