Atomstack5pro not homing correctly

just purchased an atomstacka5pro installed lightburn software followed software instruction but when i try to home device it runs over and starts jumping then send error code

Please Copy the error message from the Console window in LightBurn into a reply here. There are many different error messages. More specific information may help get you going sooner.

The A5 Pro doesn’t have limit switches, so hitting HOME sends mine crashing in to the corner and I have to kill the power.

k

[VER:1.1h.2022011001:]

[OPT:VZ,15,128]

Target buffer size found

ok

ALARM:9

Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.

ok

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

thats exactly what mine does

I suspect this is exactly what’s going on here.

This is the error that occurs when an engraver attempts a homing cycle and doesn’t reach the switch. It could be that there’s no switch.

Thank you for capturing and sharing this. This tells us about how GRBL was built for your AtomStack A5 Pro.

The option codes V and Z are Variable Spindle and Homing Force Origin.

The next step is requesting the settings report in the Console window in LightBurn by entering the following command:
$$
then press enter.
Please paste that report in your next reply here.

It’s probably going to be a matter of turning off automatic homing but the settings will tell us what the homing behavior is supposed to be.

We’re almost there.

Waiting for connection…
�ok
ok
[VER:1.1h.2022011001:]
[OPT:VZ,15,128]
Target buffer size found
ok
$$
$0=10
$1=25
$2=0
$3=0
$4=0
$5=1
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=1
$22=1
$23=3
$24=300.000
$25=3000.000
$26=250.000
$27=1.000
$30=1000.000
$31=0.000
$32=1
$37=1
$100=80.000
$101=80.000
$102=80.000
$103=100.000
$104=100.000
$105=100.000
$110=6000.000
$111=6000.000
$112=6000.000
$113=1000.000
$114=1000.000
$115=1000.000
$120=1000.000
$121=1000.000
$122=1000.000
$123=200.000
$124=200.000
$125=200.000
$130=410.000
$131=400.000
$132=200.000
$133=300.000
$134=300.000
$135=300.000
ok
hope this is correct

Homing behavior is dictated here:
$20=0 Soft Limits = 0 (off)
$21=1 Hard Limits = 1 (on)
$22=1 Homing Cycle = 1 (on)
$23=3 Homing direction invert mask = 3 (likely ok - depends on construction)
$24=300.000 (homing feed - a slow precise speed to get good repeatability)
$25=3000.000 (homing seek - a fast ‘get to the switch’ then sort it out.)
$26=250.000 (Switch debounce in milliseconds 250/1000 = 1/4 second)
$27=1.000 (switch pull-off 1mm)

This device believes that it has limit switches and can home properly.

If the limit switches are not installed on this device open the Console window in LightBurn and type the following:
$22=0
Then press enter.
This will turn off automatic homing on the engraver until the switches are installed and working. When the switches are in place, you can turn homing back on with $22=1 as it is now.

With an engraver with no limit switches, you should also turn off ‘Auto-home on start up’. You can reach that switch by clicking Edit, then clicking Device settings.

If the switches are already in place more troubleshooting may be required.

This video describes the set up of engravers with and without limit switches. The section on absolute coordinates will help get you going.

Here’s an excellent video about installing limit switches:

More information about GRBL and what all the codes mean is available here: grbl/settings.md at master · gnea/grbl · GitHub

Hope that helps get you going!

i believe that fixed that problem but now i get this

error:9
G-code locked out during alarm or jog state.
error:9
G-code locked out during alarm or jog state.
error:9
G-code locked out during alarm or jog state.
error:9
G-code locked out during alarm or jog state.
error:9
G-code locked out during alarm or jog state.
when i try to start a program i am so flustrated

`A5 PRO, as mentioned, has no limit switches nor any other mech to tell the machine where the laser head is. The machine simply calculates ‘home’ based on where it THINKS it is.

On start, manually move the laser head to the bottom left corner. When burning, it’s possible (particularly if you do small vectors/fonts with speeds too fast (> ~3000 … 3500mm/m) or the head hits an obstruction or other reasons) it might think it is in a different place than it actually is. “Homing” can then fail and other errors might occur.

Turn off the machine, manually move the laser head to the bottom left. Use Absolute positioning always (or at least begin this way until you can confirm other settings!), starting from the lower left corner.

Been using my A5 PRO for months now this way. Never a problem Well … almost :smiley:

BTW, watch out for that 2mm focus height! if you use push pins, magnets or whatever and the head hits, it will throw off your position and cause problems!!!

Have fun :slight_smile:
dvc

btw, also critical is to “lock down” your laser so it cannot move at all. Not sure if clear from this image, but, I’ve screwed in the laser legs to a base, which is resting on a table I specifically made for this, all of which is designed to prohibit even small movements as the laser head moves.


Further, I made the base so it precisely holds a honeycomb base so I can know exactly where any piece of wood I lay down is located, eliminating any need for framing or other testing/positioning.

Works very nicely for me :slight_smile:

i reinstalled laser used the $$ to stop the auto homing when i i try to engrave i got this message

$132=200.000
$133=300.000
$134=300.000
$135=300.000
error:20
Unsupported or invalid g-code command found in block.
On or near line 1:
Job halted
Stream completed in 0:00
ok

Please scroll back, past the repetition and a look to see if there is an error or warning causing this.

Please copy and paste it into a reply here.

Is it still trying to home? Did you turn off Auto Home on start up in Device Settings?

Oh…
You may want to turn off Auto-Homing on startup in Device Settings (above)

The $$ is a request for a report. It will tell you what the Machine Settings are.
It is not intended to stop homing. It will show many of the expected behaviours of the engraver.

i did the $22=0 that fixed the homing and now this happens

Homing
error:5
Homing cycle is not enabled in your Grbl settings.
Waiting for connection…
ok
[VER:1.1h.2022011001:]
[OPT:VZ,15,128]
Target buffer size found
ok
Homing
error:5
Homing cycle is not enabled in your Grbl settings.
<Idle|MPos:0.000,0.000,0.000|FS:0,0|Pn:P|WCO:0.000,0.000,0.000>
ok
Starting stream
Stream completed in 0:00
Starting stream
Layer C01
$0=10
$1=25
$2=0
$3=0
$4=0
$5=1
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=1
$22=0
$23=3
$24=300.000
$25=3000.000
$26=250.000
$27=1.000
$30=1000.000
$31=0.000
$32=1
$37=1
$100=80.000
$101=80.000
$102=80.000
$103=100.000
$104=100.000
$105=100.000
$110=6000.000
$111=6000.000
$112=6000.000
$113=1000.000
$114=1000.000
$115=1000.000
$120=1000.000
$121=1000.000
$122=1000.000
$123=200.000
$124=200.000
$125=200.000
$130=410.000
$131=400.000
$132=200.000
$133=300.000
$134=300.000
$135=300.000
error:20
Unsupported or invalid g-code command found in block.
On or near line 1:
Job halted
Stream completed in 0:00
ok
Grbl 1.1h [‘$’ for help]