Auto Focus Question

So things are going very well so far with this generic CO2 laser Ruida 64455G controller, Windows 10 OS, USB packet comms…

I have calibrated all axis And then thought, I’ll just check the auto focus.

Z’s are enabled in Lightburn
My sensor is read by the controller in diagnostics
My Z moves as required
But, yes there’s always a, but

I get this error.

I reset the controller X and Y reset and Z to 3000, then try again

I have looked, read and watched because I like to find answers, here’s another but…

Any ideas please people :blush:

Maybe I found something but I need to be with the laser and RD Works.

Still would love to hear if you can assist :blush:

Have you checked that the z-axis autofocus is set correctly in the Ruida?

Do your z-axis keys work properly on the panel?

Has the controller been set to use autofocus? the message indicates that there isn’t a sensor set up to use autofocus.

Following this

Also use 64455 in FW 15.01.15 auto focus working normally, but in all later versions (.16 .18 .19 .22) auto focus not working (manual reset z axis working normally)
How to fix this?

LP

Ah… Then all is good. I AM WITH FIRMWARE 22

Thank you I had read about the middle numbers but not 22.

I will wait for an update, it’s not fatal.

Again, thanks :+1::blush:

It would be unusual for a later firmware to reduce functionality.

Have you enabled Z-axis limit switch in firmware?

Yes and it shows in the diagnostic screen…

When I activate the sensor the controller sees it and displays its state :+1:

There could of course be a second layer to this so will try in the morning when I get in there.
Thanks Bo for following up on this :+1:

Hi Bo, I went through the controller, RD Works and LightBurn today, every page of every Z related setting and said “yes please” to everything, trying the auto focus every step and

:frowning:
Sadly, the same error keeps appearing

Tomorrow is another day :slight_smile: and there’s an answer out there somewhere :))

The message ‘Z axis does not enable reset’ indicates that there is no limit switch enabled on the Z axis or cannot be detected at initialisation.

Some key points - including that the controller and stepper drivers must share a common ground (anode), or the level cannot be determined:

this should always be the case, anyway - so many problems I encounter are related to poor or bad earth.

If you make everything in your setup use a common ground, you can’t go wrong - laser tube, LPSU, drive/controller PSUs, controller, drivers, coolant reservoir, should all use the same ground.

All input AC power sources - power supplies, cooler, fan, air pump - should similarly use a common ground tied to AC power earth. I’m not a fan of tying your DC ground to your AC earth as things like your powerful extractor fan can cause glitches in your DC-powered devices, like your controller.

If your controller resets when you turn your fan on, it’s a good indicator that your DC is tied to your chassis ground on the machine. Most cheap machines are and people/OEM do it because it’s convenient, but run the wire - it’s a small inconvenience one time to ensure reliability and glitch-free operation.

Hi Bo, I’m on my way there at the moment. The autofocus did, when I first got the machine, work.

Therefore I am going to presume that earth bonding is correct as I have not yet touched anything there, yet !

The bed has no visible inductive, micro switch, or other sensor visible in the enclosure but better will be for me to look on the controller for leads to the relevant ports.

The Z sensor ( autofocus) works reliability at least for a 100 or so operations manually checked with both a multimeter and in the controller interface indicated by the illumination of the red square. (See image in previous post)

I will check earth’s of course, anything can move, anything :slight_smile:

I really appreciate your inputs and always find them enlightening.

Where’s that hammer !!! :shushing_face::crazy_face:

Well, as far as I can see and test with a continuity tester, the common ground side looks good.

The controller has just one sensor into the Z

As you see from the image and those cables go to the auto focus sensor. Now I did test that, as I mentioned in the previous post, but, I have another sensor on its way and will swap it out and try it.

Step by step as we say here in Bulgaria :shushing_face::crazy_face:

I just read this in RDWORKS Lab so I will give it a try tomorrow…


Post
by Aaron Fuerlinger » Mon May 25, 2020 12:25 pm

I disabled Autofocus in the 6445 Controller.
Now for me it works well.
Give it a try.
If I Hit now Focus it drives the bed up to the switch and then lowers a little bit and touches the switch again. And Set the Focus without driving All the way down. I think I have seen the same behavior in one of russ Videos about autofocus.

Its not impossible to get one little bit of code wrong :slight_smile: so I will try it :))

Heres a quote from another guy there

Post
by Joseph Abenhaim » Tue May 26, 2020 3:05 pm

Aaron Fuerlinger wrote:

Mon May 25, 2020 12:25 pm

I disabled Autofocus in the 6445 Controller.
Now for me it works well.
Give it a try.
If I Hit now Focus it drives the bed up to the switch and then lowers a little bit and touches the switch again. And Set the Focus without driving All the way down. I think I have seen the same behavior in one of russ Videos about autofocus.
Dang, that was it! Disabled auto focus in focusing menu and now it behaves correctly, pretty counter intuitive lol Thanks again!

AND WHILE READING THAT… MOMENT DRUM ROLLLLLLL

While I was going through the controller about day 2 I got to the focus screen and there there are two windows for acivate the Focus and One of them was to NO… I like a fool thought that cant be correct and set it to “YES” be active… Then I went home… recovering from Covid had me really tired… The next day I didnt check it then when I did, I forgot about the setting of the NO to YES in the focus panel…

Tomorrow, first thing on the list
Turn off The Auto Focus and watch it work :slight_smile:
Let hope :crazy_face:

Good luck.

At least you are fully-conversant with the autofocus feature, now :slight_smile:

You will need to write a short primer, with checks.

Well, that didn’t work :grin::grin::clown_face:

But it did, during certain combinations, alter the error message.

So back to the drawing board but with more chalk :sunglasses::sunglasses::sunglasses: