Auto home on startup grbl 1.1f

Hello,
i have GRBL 1.1f with homing enabled and hard limits.
through devices, i have it configured for auto home on startup
the machine does home when click button and goes to origin when clicked
i have G10 for negative space set.

is program/machine actually supposed to auto home when first connected or is it user controlled only?
is there a way to have auto home with $Nx or another way.
it gives me errors when i try to assign ($N0=$H).


It should trigger the home command when it first connects, yes. Does it not do this? Can you show what the console says when you first connect to the controller?

What the heck is “Grbl Gizmo Laser”? That’s a new one for me. Where did this version of GRBL come from? The maximum speeds are really low for a K40 (1500mm/min) as well.

it is the GRBL 1.1f version for uno/nano
i just put my “special” name in there

i have the feeds down because i was trying to troubleshoot issues. ended up being bad X motor.

i tried to add new device with auto home disabled, restarted and then edited to re-enable again.
did not make any difference.