Auto Home setting my X0,Y:170 instead of X:0,Y:0 Why?

Whenever I hit the HOME button, my NEJE will auto-home normally to X:0 Y:0 however Lightburn reports the position as X:0 Y:170.

Why is my Y so far off? What am I missing?

Because the homing switches are in the left upper corner, not at the “origin” position (0,0) at the lower left corner.

Oh interesting so it’s reverse on a NEJE.
I’m new to Lightburn, Is there a setting to flip Origin position so 0,170 = 0,0?
Or Am I just talking crazy now?5

Got it.

  1. Click Edit
  2. Machine Settings.
  3. Outputs Setup
  4. CHANGED Y Max travel (mm) from 170.00 to 0.00
  5. Write

Now my NEJE reports 0,0 when I auto-home.
Thanks for the Hint.

What? I doubt this will give you any meaningful result.


0,0 is called origin and is bottom left of the machine.

0,170 is the where the homing switches are and is at the top left of the machine.

Every Y position between 0 and 170 is somewhere between those. Higher Y values are up, lower ones are down.

(And X obviously goes from 0 near the Y rail to 170(?) far away to the right of it.)

If you make it report 0,0 at the homing position and then want to drive to 100,100; the laser would want to move 100mm away from the Y rail for X=100 and 100mm UP along the Y rail, driving over the end of the rail, through the electronics board and onto your counter.



AHHH! Maybe that’s why. My LB was set up as the 170 model initialy.
I have the “NEJE Master 2S PLUS” which is 255 X 420 MM. Maybe it’s backwords because changing that setting works perfectly now. goto 250,420 and it goes to the bottom right. goto 0,0 and it goes to top left.

Attached my lbset

NEJE-Master2S+_FIXED-XY.lbset (5.4 KB)

I assumed the mini because of the 170. I have a plus, too, and the coordinates should be as I painted on the picture above. The electronics board is in the top/left corner (X=0/Y=440 is the homing position, that’s actually 20mm above the highest usable Y value) and “origin” (0/0) is at the other end of the Y rail.

If you got it to flip the Y axis, your output should also be upside down? No idea, those machines can be configured to do all kinds of coordinate translations and the changes NEJE did to grbl don’t make it easier. (e.g. grbl expects homing switches either at +MAX or -MAX, never at 0)

These settings work with the firmware at default settings if you ever want to reset your machine:

Okay, this makes more sense. My Return to Finish is different than yours so maybe that’s why this works for me… I have x:0 y:170

When I hit HOME it auto-homes and reports 0,0

“Return to Finish” you can set to any position, there’s nothing special about it. I selected a position that is out of my way but still above the border of the honeycomb table.

So what you have done is to say your machine that its workspace is 0mm high. This makes 0 and +MAX the same position. Then you have told LightBurn to drive the laser into negative Y space (Origin set to top/left). And because the machine doesn’t care—if you were to tell it to drive to X=15km, Y=-30,000km it would happily try to rip itself apart for days—this works.

That’s funny because I just told it to goto X:800 - Y:800 and it happily moved to the end of the rails and stops right at X:255 - Y:420

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.