Backwards in lightburn

I just bought a omtech 100w co2 laser with a bed size of 24 x 40 and my question is that when I set up my pattern in lightburn I now have to reverse it before sending it to the laser otherwise it’s backwards, also if I move my laser head in lightburn to the bottom left corner it instead goes to the right. Is this normal with this new version ruida control panel

You don’t mention the model of controller but in either case no, it’s likely not normal.

How have you set the Origin of the device in LightBurn? Check this in Edit->Device Settings. For your machine, you need to set the Origin corner to the same corner that your machine homes. I assume your machine is back left or back right. I’m guessing your current position is front left or front right.

This document will explain how things work, and what you have configured incorrectly as well as how to resolve the issue:

I have an Omtech 80w and it homes top right.
Mine came with the cheaper Ruida knock-off controller, had the same problem with mirrored image.
Tried everything to get it right but in the end I had to settle for the correct image on Lightburn and upside-down on the controller, works fine, It engraves the correct way up.
It’s always something simple, just a matter of finding it :thinking:

You can likely resolve this by going to “Screen Origin” Setting on your Control Panel and changing that to match your machine origin. On the 6442 you get there by pushing the Z/U button but I believe your controller may have a different button to get there.

Nice one ,thank you, i’ll give it a try next time i can get time on the my laser :+1:

1 Like