Belt skip and jumping machine when FRAME is selected

Neje Master 2s Plus. GRBL 1.1f, LB

Finally got it to work with LB thanks to Northwood’s directions. The only problem I have really is when selecting FRAME. It appears to ignore the endstops. HOME works fine, just happens when framing.
Any ideas how to fix this?

slow down the speed value in the Move window

Nope that’s not the issue. Now I’m lost again and I think this is the problem. If I Home it goes to the correct place but of course the endstops keep it from going any further. But when the laser is at the Home position and I select “Get Position” it returns X0 but Y170.

If I tell it to go to 0:0 it goes to X0 but nearly center of Y.

Hope somebody can help. I searched for the problem and found somebody else reporting the same but was an old Mac version that looked quite different than my config screens and I couldn’t relate to it.

Sounds like some GRBL settings related to origin have been set. Look around for information on clearing that on the NEJE and I’m not talking about just uploading new firmware because other parts of the flash memory stores firmware and other parts store settings.

This is what I found is supposed to clear settings and reload defaults -


How/where do I enter this?

Did you not find anything on NEJE sites/forums talking about resetting the firmware to defaults?
Because you have to ask, I’m hesitant to tell you where to enter the commands as it can be a long road if everything is a step-by-step if something doesn’t work…

Have you tried the Set Origin button on the Move Tab? What I mean is have to moved the laser to a position after it homed the machine, cleared the origin(there’s a button) then clicked “Set Origin” button, THEN moved the laser to another location or home and clicked the GoTo Origin and validated it moved to where you set the origin.

Obviously I’m new to LB but definitely not resetting, firmware uploading etc as an advanced arduino & other microcontrollers and 3D printer control boards etc.
I just don’t recall seeing anyplace to enter commands in the console.

1 Like

Fantastic, then you’ll know how to save your existing GRBL configuration($$) and reset things if NEJE did not set appropriate defaults withing the GRBL firmware.

$RST=* sets config to defaults and clears other firmware data areas.
hint: Configuring Grbl v0.9 · grbl/grbl Wiki · GitHub

This did the trick in a roundabout way. After clearing and about to re-import the device profile when I checked the profile and found it to have the incorrect work area. Edited the file and checked all of the other settings then imported and tested. Bazinga!
Had I not cleared the board it may have taken hours or days to figure out the file was incorrect.
Peace & Thanks.

1 Like